]> git.pld-linux.org Git - packages/perl-Regexp-Common.git/blob - perl-Regexp-Common.spec
- updated to 2.117
[packages/perl-Regexp-Common.git] / perl-Regexp-Common.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Regexp
7 %define pnam    Common
8 Summary:        Regexp::Common Perl module - commonly requested regular expressions
9 Summary(pl):    Modu³ Perla Regexp::Common - czêsto u¿ywane wyra¿enia regularne
10 Name:           perl-Regexp-Common
11 Version:        2.117
12 Release:        1
13 License:        Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  1ccecab99f7ae4f42c3428f07d5f8731
17 Patch0:         %{name}-test.patch
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 # not recognized for unknown reason
24 %define         _noautoreq      'perl(Regexp::Common::URI)'
25
26 %description
27 This package contains Regexp::Common module that stores or generates
28 commonly needed regular expressions. Patterns currently provided
29 include:
30  * balanced parentheses and brackets
31  * delimited text (with escapes)
32  * integers and floating-point numbers in any base (up to 36)
33  * comments in C, C++, Perl, and shell
34  * offensive language
35  * lists of any pattern
36  * IPv4 addresses
37  * URIs
38
39 %description -l pl
40 Ten pakiet zawiera modu³ Regexp::Common, który zawiera lub generuje
41 czêsto potrzebne wyra¿enia regularne. Aktualnie zawiera wzorce dla:
42  * zrównowa¿onych nawiasów
43  * ograniczonego tekstu (z cytowaniem)
44  * liczb ca³kowitych i zmiennoprzecinkowych o dowolnej podstawie (do 36)
45  * komentarzy w C, C++, Perlu i shellu
46  * s³ów obra¼liwych (w jêzyku angielskim)
47  * list o dowolnym wzorcu
48  * adresów IPv4.
49  * URI
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-%{version}
53 # Not sure if this patch is still needed
54 #%patch0 -p1
55
56 %{__perl} -pi -e 's/^(use 5.004)(73;)(.*)$/$1_$2$3/' lib/Regexp/Common.pm
57
58 %build
59 %{__perl} Makefile.PL \
60         INSTALLDIRS=vendor
61 %{__make}
62
63 %{?with_tests:%{__make} test}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %{__make} install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc README TODO
77 %{perl_vendorlib}/Regexp/*.pm
78 %{perl_vendorlib}/Regexp/Common
79 %{_mandir}/man3/*
This page took 0.068316 seconds and 3 git commands to generate.