]> git.pld-linux.org Git - SPECS.git/blob - perl-RRD-Editor.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / perl-RRD-Editor.spec
1 # Conditional build:
2 %bcond_without  tests           # do not perform "make test"
3 #
4 %define         pdir    RRD
5 %define         pnam    Editor
6 Summary:        Portable, standalone (no need for RRDs.pm) tool to create and edit RRD files
7 Name:           perl-RRD-Editor
8 Version:        0.16
9 Release:        1
10 License:        GPL v1+ or Artistic
11 Group:          Development/Languages/Perl
12 Source0:        http://www.cpan.org/modules/by-module/RRD/%{pdir}-%{pnam}-%{version}.tar.gz
13 # Source0-md5:  41d2d4feec7dbe748cde9aee1343debb
14 URL:            http://search.cpan.org/dist/RRD-Editor/
15 BuildRequires:  perl-devel >= 1:5.8.0
16 BuildRequires:  rpm-perlprov >= 4.1-13
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 RRD:Editor implements most of the functionality of RRDTOOL, apart from
22 graphing, plus adds some new editing and portability features. It aims
23 to be portable and self-contained (no need for RRDs.pm).
24
25 RRD::Editor provides the ability to add/delete DSs and RRAs and to
26 get/set most of the parameters in DSs and RRAs (renaming, resizing
27 etc). It also allows the data values stored in each RRA to be
28 inspected and changed individually. That is, it provides almost
29 complete control over the contents of an RRD.
30
31 The RRD files created by RRDTOOL use a binary format (let's call it
32 native-double) that is not portable across platforms. In addition to
33 this file format, RRD:Editor provides two new portable file formats
34 (portable-double and portable-single) that allow the exchange of
35 files. RRD::Editor can freely convert RRD files between these three
36 formats (native-double,portable-double and portable-single).
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} pure_install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorlib}/RRD
61 %{_mandir}/man3/*.3*
This page took 0.866453 seconds and 3 git commands to generate.