]> git.pld-linux.org Git - packages/perl-Pegex.git/blob - perl-Pegex.spec
- new
[packages/perl-Pegex.git] / perl-Pegex.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Pegex
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Pegex - Acmeist PEG Parser Framework
8 Summary(pl.UTF-8):      Pegex - szkielet analizatora Acmeist PEG
9 Name:           perl-Pegex
10 Version:        0.60
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/I/IN/INGY/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  347f72c1c0347148d80058ea35927df8
17 URL:            http://search.cpan.org/dist/Pegex/
18 BuildRequires:  perl-File-ShareDir-Install >= 0.06
19 BuildRequires:  perl-devel >= 1:5.8.1
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-YAML-LibYAML
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Pegex is an Acmeist parser framework. It allows you to easily create
29 parsers that will work equivalently in lots of programming languages!
30 The inspiration for Pegex comes from the parsing engine upon which the
31 postmodern programming language Perl 6 is based on. Pegex brings this
32 beauty to the other justmodern languages that have a normal regular
33 expression engine available.
34
35 Pegex gets it name by combining Parsing Expression Grammars (PEG),
36 with Regular Expessions (Regex). That's actually what Pegex does.
37
38 %description -l pl.UTF-8
39 Pegex to szkielet analizatora Acmeist. Pozwala łatwo tworzyć
40 analizatory działające tak samo w wielu językach programowania. Pegex
41 jest zainspirowany silnikiem analizującym, na którym jest oparty
42 postmodernistyczny język Perl 6. Pegex dostarcza o piękno do innych
43 współczesnych języków, mających dostępny zwykły silnik wyrażeń
44 regularnych.
45
46 Nazwa Pegex pochodzi z połączenia skrótu PEG (Parsing Expression
47 Grammars) z Regex (Regular Expressions). I oznacza to, co właściwie
48 Pegex robi.
49
50 %prep
51 %setup -q -n %{pdir}-%{version}
52
53 %build
54 %{__perl} Makefile.PL \
55         INSTALLDIRS=vendor
56 %{__make}
57
58 %{?with_tests:%{__make} test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} pure_install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Pegex.pod
67
68 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
69 cp -a example $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc Changes
77 %{perl_vendorlib}/Pegex.pm
78 %{perl_vendorlib}/Pegex
79 %{perl_vendorlib}/auto/share/dist/Pegex
80 %{_mandir}/man3/Pegex.3pm*
81 %{_mandir}/man3/Pegex::*.3pm*
82 %{_examplesdir}/%{name}-%{version}
This page took 0.117612 seconds and 3 git commands to generate.