]> git.pld-linux.org Git - SPECS.git/blob - perl-PathTools.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-PathTools.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    PathTools
6 Summary:        Get pathname of current working directory
7 Summary(pl.UTF-8):      Pobieranie ścieżki bieżącego katalogu
8 Name:           perl-PathTools
9 Version:        3.62
10 Release:        1
11 Epoch:          1
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/R/RJ/RJBS/%{pdir}-%{version}.tar.gz
15 # Source0-md5:  bfe148a89064078cf162504c30a4c41a
16 URL:            http://search.cpan.org/dist/PathTools/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 PathTools merges Cwd and File::Spec into a single distribution.
23 This was done because the two modules use each other fairly
24 extensively, and extracting the common stuff into another distribution
25 was deemed nigh-impossible.
26
27 Cwd provides functions for determining the pathname of the current
28 working directory.  It is recommended that getcwd (or another *cwd()
29 function) be used in _all_ code to ensure portability.
30
31 File::Spec is designed to support operations commonly performed on
32 file specifications (usually called "file names", but not to be
33 confused with the contents of a file, or Perl's file handles), such as
34 concatenating several directory and file names into a single path, or
35 determining whether a path is rooted.
36
37 %description -l pl.UTF-8
38 PathTools łączy Cwd i File::Spec w jeden pakiet. Został zrobiony
39 ponieważ te dwa moduły używają intensywnie siebie nawzajem i
40 wyciągnięcie wspólnego kodu do oddzielnego pakietu zostało uznane za
41 prawie niemożliwe.
42
43 Cwd dostarcza funkcje do określania ścieżki bieżącego katalogu.
44 Zalecane jest używanie getcwd (lub innej funkcji *cwd()) w _całym_
45 kodzie dla zapewnienia przenośności.
46
47 File::Spec jest zaprojektowany do obsługi operacji zwykle
48 przeprowadzanych na określeniach plików (zwykle nazywanych "nazwami
49 plików", których nie należy mylić z zawartością plików czy perlowymi
50 uchwytami plików), takich jak łączenie kilku katalogów i nazw plików w
51 pojedynczą ścieżkę albo określanie czy ścieżka jest podana względem
52 głównego katalogu.
53
54 %prep
55 %setup -q -n %{pdir}-%{version}
56
57 %build
58 %{__perl} Makefile.PL \
59         INSTALLDIRS=vendor
60 %{__make} \
61         CC="%{__cc}" \
62         OPTIMIZE="%{rpmcflags}"
63
64 %{?with_tests:%{__make} test}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc Changes README
78 %{perl_vendorarch}/Cwd.pm
79 %{perl_vendorarch}/File/Spec.pm
80 %{perl_vendorarch}/File/Spec
81 %dir %{perl_vendorarch}/auto/Cwd
82 %attr(755,root,root) %{perl_vendorarch}/auto/Cwd/Cwd.so
83 %{_mandir}/man3/Cwd.3pm*
84 %{_mandir}/man3/File::Spec*.3pm*
This page took 0.527799 seconds and 3 git commands to generate.