]> git.pld-linux.org Git - packages/perl-Path-Class.git/blob - perl-Path-Class.spec
985a6c64ec21d5e3780362542d02827777ae2e0f
[packages/perl-Path-Class.git] / perl-Path-Class.spec
1 #
2 # Conditional build:
3 # Tests fail because our perl does not contain File::Spec::Win32 and
4 # other "foreign" modules
5 %bcond_with     tests   # perform "./Build test"
6
7 %include        /usr/lib/rpm/macros.perl
8 %define pdir    Path
9 %define pnam    Class
10 Summary:        Cross-platform path specification manipulation
11 Name:           perl-Path-Class
12 Version:        0.03_01
13 Release:        1
14 # same as Perl
15 License:        GPL or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/authors/id/K/KW/KWILLIAMS/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  d5531392cd65c9221e21627ef8dab2a2
19 Patch0:         %{name}-test-bareword.patch
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  perl-Module-Build >= 0.20
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 #%define                _noautoreq      'perl(anything_fake_or_conditional)'
27
28 %description
29 Path::Class is a module for manipulation of file and directory
30 specifications (strings describing their locations, like
31 '/home/ken/foo.txt' or 'C:\Windows\Foo.txt') in a cross-platform
32 manner. It supports pretty much every platform Perl runs on, including
33 Unix, Windows, Mac, VMS, Epoc, Cygwin, OS/2, and NetWare.
34
35 The well-known module File::Spec also provides this service, but it's
36 sort of awkward to use well, so people sometimes avoid it, or use it
37 in a way that won't actually work properly on platforms significantly
38 different than the ones they've tested their code on.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42 %patch0 -p1
43
44 %build
45 %{__perl} Build.PL \
46         installdirs=vendor \
47         destdir=$RPM_BUILD_ROOT
48
49 ./Build
50 %{?with_tests:./Build test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 ./Build install
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes
63 %{perl_vendorlib}/Path
64 %{_mandir}/man3/*
This page took 0.047647 seconds and 2 git commands to generate.