]> git.pld-linux.org Git - packages/perl-Parse-RecDescent.git/blob - perl-Parse-RecDescent.spec
- updated _noauto for new wrappers, cosmetics
[packages/perl-Parse-RecDescent.git] / perl-Parse-RecDescent.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Parse
7 %define         pnam    RecDescent
8 Summary:        Parse::RecDescent - generate recursive-descent parsers
9 Summary(pl):    Parse::RecDescent - generowanie zmniejszaj±cych rekurencyjnie analizatorów
10 Name:           perl-Parse-RecDescent
11 Version:        1.94
12 Release:        2
13 License:        Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  497600b337a501eae11f31195ccec9d4
17 Patch0:         %{name}-paths.patch
18 BuildRequires:  perl-Text-Balanced
19 BuildRequires:  perl-devel >= 5.6.1
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 # these versions included own copy of Text::Balanced
22 BuildConflicts: perl-Parse-RecDescent < 1.92
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _noautoreq      'perl(Calc)'
27
28 %description
29 RecDescent incrementally generates top-down recursive-descent text
30 parsers from simple yacc-like grammar specifications. It provides:
31  * Regular expressions or literal strings as terminals (tokens),
32  * Multiple (non-contiguous) productions for any rule,
33  * Repeated, optional and alternate subrules within productions,
34  * Late-bound (run-time dispatched) subrules,
35  * Full access to Perl within actions specified as part of the
36    grammar,
37  * Simple automated error reporting during parser generation and
38    parsing,
39  * The ability to commit to, uncommit to, or reject particular
40    productions during a parse,
41  * Incremental extension of the parsing grammar (even during a
42    parse),
43  * Precompilation of parser objects,
44  * User-definable reduce-reduce conflict resolution via
45    "scoring" of matching productions.
46
47 %description -l pl
48 RecDescent generuje przyrostowo zstêpuj±ce, zmniejszaj±ce
49 rekurencyjnie analizatory tekstu w oparciu o prost± specyfikacjê
50 gramatyki, podobn± do u¿ywanej przez yacca. Udostêpnia on:
51  * Wyra¿enia regularne i ³añcuchy litera³ów jako terminale (tokeny),
52  * Wielokrotn± (nieci±g³±) produkcjê dla ka¿dej regu³y,
53  * Powtarzane, opcjonalne i alternatywne podregu³y w obrêbie
54    produkcji,
55  * Podregu³y pó¼nego wi±zania (wysy³ane w chwili uruchomienia),
56  * Pe³en dostêp do Perla w obrêbie akcji okre¶lonych jako czê¶æ
57    gramatyki,
58  * Proste, zautomatyzowane sygnalizowanie b³êdów podczas generacji
59    analizatora i podczas analizy,
60  * Mo¿liwo¶æ zatwierdzenia, cofniêcia oraz odrzucania poszczególnych
61    produkcji podczas analizy,
62  * Przyrostowe rozszerzanie gramatyki podlegaj±cej analizie (nawet
63    podczas samej analizy),
64  * Prekompilacjê obiektów analizatora,
65  * Definiowalne przez u¿ytkownika rozpoznawanie konfliktów
66    "reduce-reduce" poprzez ocenianie dopasowania produkcji.
67
68 %prep
69 %setup -q -n %{pdir}-%{pnam}-%{version}
70 %patch0 -p1
71
72 %build
73 %{__perl} Makefile.PL \
74         INSTALLDIRS=vendor
75 %{__make}
76 %{!?_without_tests:%{__make} test}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %{__make} install \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %doc README Changes
90 %{perl_vendorlib}/Parse/*.pm
91 %{_mandir}/man3/*
This page took 0.029513 seconds and 3 git commands to generate.