]> git.pld-linux.org Git - packages/perl-Params-Classify.git/blob - perl-Params-Classify.spec
- new
[packages/perl-Params-Classify.git] / perl-Params-Classify.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Params
6 %define         pnam    Classify
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Params::Classify - argument type classification
9 #Summary(pl.UTF-8):     
10 Name:           perl-Params-Classify
11 Version:        0.013
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Params/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  63d24fbec775472ada49d16bce4a9b1f
18 # generic URL, check or change before uncommenting
19 #URL:           http://search.cpan.org/dist/Params-Classify/
20 BuildRequires:  perl-Module-Build
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with tests}
24 %endif
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module provides various type-testing functions.  These are
29 intended for functions that, unlike most Perl code, care what type of
30 data they are operating on.  For example, some functions wish to
31 behave differently depending on the type of their arguments (like
32 overloaded functions in C++).
33
34 There are two flavours of function in this module.  Functions of the
35 first flavour only provide type classification, to allow code to
36 discriminate between argument types.  Functions of the second flavour
37 package up the most common type of type discrimination: checking that
38 an argument is of an expected type.  The functions come in matched
39 pairs, of the two flavours, and so the type enforcement functions
40 handle only the simplest requirements for arguments of the types
41 handled by the classification functions.  Enforcement of more complex
42 types may, of course, be built using the classification functions, or
43 it may be more convenient to use a module designed for the more
44 complex job, such as Params::Validate.
45
46 # %description -l pl.UTF-8
47 # TODO
48
49 %prep
50 %setup -q -n %{pdir}-%{pnam}-%{version}
51
52 %build
53 %{__perl} Build.PL \
54         destdir=$RPM_BUILD_ROOT \
55         installdirs=vendor
56 ./Build
57
58 %{?with_tests:./Build test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 ./Build install
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes README
71 %{perl_vendorarch}/Params/*.pm
72 %dir %{perl_vendorarch}/auto/Params/Classify
73 %{perl_vendorarch}/auto/Params/Classify/*.bs
74 %attr(755,root,root) %{perl_vendorarch}/auto/Params/Classify/*.so
75 %{_mandir}/man3/*
This page took 0.036916 seconds and 3 git commands to generate.