]> git.pld-linux.org Git - packages/perl-Package-Variant.git/blob - perl-Package-Variant.spec
5154499991f3d2be7b66b86d9f9121a5f4ddf13a
[packages/perl-Package-Variant.git] / perl-Package-Variant.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Package
6 %define         pnam    Variant
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Package::Variant - Parameterizable packages
9 #Summary(pl.UTF-8):     
10 Name:           perl-Package-Variant
11 Version:        1.002000
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Package/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  fc0b756835c26d6d6dca711021fb94c0
18 URL:            http://search.cpan.org/dist/Package-Variant/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Import-Into >= 1
23 BuildRequires:  perl-Module-Runtime >= 0.013
24 BuildRequires:  perl-strictures >= 1
25 BuildRequires:  perl-Test-Fatal
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This module allows you to build packages that return different
32 variations depending on what parameters are given.
33
34 Users of your package will receive a subroutine able to take
35 parameters and return the name of a suitable variant package.
36 The implementation does not care about what kind of package it builds.
37
38 There are two important parts to creating a variable package. You
39 first have to give Package::Variant some basic information about what
40 kind of package you want to provide, and how. The second part is
41 implementing a method receiving the user's arguments and generating
42 your variants.
43
44 # %description -l pl.UTF-8
45 # TODO
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53 %{__make}
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} pure_install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes README
69 %{perl_vendorlib}/Package/Variant.pm
70 %{_mandir}/man3/*
This page took 0.077987 seconds and 3 git commands to generate.