]> git.pld-linux.org Git - packages/perl-POE-Component-Client-Keepalive.git/blob - perl-POE-Component-Client-Keepalive.spec
- initial, 0.801, rel 0.1, builds here
[packages/perl-POE-Component-Client-Keepalive.git] / perl-POE-Component-Client-Keepalive.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_without  tests   # do not perform "make test"
5 #
6 %include        /usr/lib/rpm/macros.perl
7 %define         pdir    POE
8 %define         pnam    Component-Client-Keepalive
9 Summary:        perl(POE::Component::Client::Keepalive)
10 Name:           perl-POE-Component-Client-Keepalive
11 Version:        0.0801
12 Release:        0.1
13 # note if it is "same as perl"
14 License:        (enter GPL/LGPL/BSD/BSD-like/Artistic/other license name here)
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 #Patch0:                %{name}
18 # most of CPAN modules have generic URL (substitute pdir and pnam here)
19 #URL:           http://search.cpan.org/dist/%{pdir}-%{pnam}
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 #BuildRequires: -
23 %if %{with autodeps} || %{with tests}
24 #BuildRequires: perl-
25 #BuildRequires: perl-
26 %endif
27 #Requires:      -
28 #Provides:      -
29 #Obsoletes:     -
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 #%define                _noautoreq      'perl(anything_fake_or_conditional)'
34
35 %description
36 #
37 #%description -l pl
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41 #%patch0 -p1
42
43 %build
44 # Don't use pipes here: they generally don't work. Apply a patch.
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47
48 %{__make}
49 # if module isn't noarch, use:
50 # %{__make} \
51 #       OPTIMIZE="%{rpmcflags}"
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} pure_install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc CHANGES README
67 # note it's mostly easier to copy unpackaged filelist here, and run adapter over the spec.
68 # use macros:
69 %{perl_vendorlib}/POE/Component/Client/Keepalive.pm
70 %dir %{perl_vendorlib}/POE/Component/Connection
71 %{perl_vendorlib}/POE/Component/Connection/Keepalive.pm
72 %{_mandir}/man3/*
This page took 0.10871 seconds and 3 git commands to generate.