]> git.pld-linux.org Git - packages/perl-POE-Component-Client-Ident.git/blob - perl-POE-Component-Client-Ident.spec
7507d9e95371906a32149a146527fbb861d10d94
[packages/perl-POE-Component-Client-Ident.git] / perl-POE-Component-Client-Ident.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    POE
7 %define pnam    Component-Client-Ident
8 Summary:        POE::Filter::Ident - A POE-based parser for the Ident protocol
9 Summary(pl.UTF-8):      POE::Filter::Ident - oparty na POE analizator protokołu Ident
10 Name:           perl-POE-Component-Client-Ident
11 Version:        1.05
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/POE/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  4957a042e4dd5710b75ac7b911dde2c4
18 URL:            http://search.cpan.org/dist/POE-Component-Client-Ident/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-POE >= 0.0607
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 POE::Filter::Ident takes lines of raw Ident input and turns them into
29 weird little data structures, suitable for feeding to
30 POE::Component::Client::Ident::Agent. They look like this: 
31
32 { name => 'event name', args => [ some info about the event ] }
33
34 %description -l pl # TODO
35 POE::Filter::Ident przyjmuje linie surowego wejścia od Identa i
36 zamienia je na dziwne małe struktury danych, nadające się do
37 przekazywania do modułu POE::Component::Client::Ident::Agent.
38 Wyglądają tak:
39
40 { name => 'nazwa zdarzenia', args => [ informacja o zdarzeniu ] }
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README
64 %{perl_vendorlib}/POE/Component/Client/*.pm
65 %{perl_vendorlib}/POE/Component/Client/Ident
66 %{perl_vendorlib}/POE/Filter/Ident.pm
67 %{_mandir}/man3/*
This page took 0.034463 seconds and 2 git commands to generate.