]> git.pld-linux.org Git - packages/perl-Net-SSLeay.git/blob - perl-Net-SSLeay.spec
a9a89aac92560665b1dd8f81812ca0cb0a373c4c
[packages/perl-Net-SSLeay.git] / perl-Net-SSLeay.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        Net::SSLeay - Perl extension for using OpenSSL or SSLeay
7 Summary(pl.UTF-8):      Net::SSLeay - rozszerzenie Perla do używania OpenSSL lub SSLeay
8 Name:           perl-Net-SSLeay
9 Version:        1.30
10 Release:        5
11 # same as openssl
12 License:        Apache-like
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Net/Net_SSLeay.pm-%{version}.tar.gz
15 # Source0-md5:  b0cd6c1681bbc0695d81be5cd852d1d0
16 Patch0:         %{name}-paths.patch
17 Patch1:         %{name}-network_tests.patch
18 URL:            http://search.cpan.org/dist/Net_SSLeay.pm/
19 BuildRequires:  openssl-devel >= 0.9.7d
20 BuildRequires:  openssl-tools >= 0.9.7d
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This module offers some high level convinience functions for accessing
27 web pages on SSL servers, a sslcat() function for writing your own
28 clients, and finally access to the SSL api of SSLeay/OpenSSL package
29 so you can write servers or clients for more complicated applications.
30
31 %description -l pl.UTF-8
32 Ten moduł oferuje kilka wygodnych funkcji wysokiego poziomu służących
33 do dostępu do stron WWW na serwerach SSL, funkcję sslcat() do pisania
34 własnych klientów, oraz dostęp do API SSL pakietu SSLeay/OpenSSL, co
35 pozwala na pisanie serwerów lub klientów dla bardziej skomplikowanych
36 aplikacji.
37
38 %prep
39 %setup -q -n Net_SSLeay.pm-%{version}
40 %patch0 -p1
41 %patch1 -p1
42
43 %build
44 %{__perl} Makefile.PL %{_prefix} \
45         INSTALLDIRS=vendor
46 %{__make} \
47         CC="%{__cc}" \
48         OPTIMIZE="%{rpmcflags}"
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
55
56 %{__make} pure_install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 install examples/*.{pl,conf} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes Credits README
67 %{perl_vendorarch}/Net/SSLeay.pm
68 %{perl_vendorarch}/Net/SSLeay
69 %{perl_vendorarch}/Net/ptrtstrun.pl
70 %dir %{perl_vendorarch}/auto/Net/SSLeay
71 %{perl_vendorarch}/auto/Net/SSLeay/autosplit.ix
72 %{perl_vendorarch}/auto/Net/SSLeay/*.al
73 %{perl_vendorarch}/auto/Net/SSLeay/*.bs
74 %attr(755,root,root) %{perl_vendorarch}/auto/Net/SSLeay/*.so
75 %{_mandir}/man3/*
76 %{_examplesdir}/%{name}-%{version}
This page took 0.02028 seconds and 2 git commands to generate.