]> git.pld-linux.org Git - packages/perl-Net-SSH2.git/blob - perl-Net-SSH2.spec
- rebuild with perl 5.26
[packages/perl-Net-SSH2.git] / perl-Net-SSH2.spec
1 #
2 # Conditional build:
3 %bcond_without  tests # do not perform "make test"
4
5 %define         pdir    Net
6 %define         pnam    SSH2
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Net::SSH2 Perl module - support for the SSH 2 protocol via libssh2
9 Summary(pl.UTF-8):      Moduł Perla Net::SSH2 - obsługa protokołu SSH 2 poprzez libssh2
10 Name:           perl-Net-SSH2
11 Version:        0.63
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  bcac41475b9f8f20a791bcc410fee912
18 URL:            http://search.cpan.org/dist/Net-SSH2/
19 BuildRequires:  libssh2-devel >= 1.7.0
20 BuildRequires:  openssl-devel
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRequires:  zlib-devel
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Net::SSH2 is a Perl interface to the libssh2 (http://www.libssh2.org/)
28 library. It supports the SSH 2 protocol (there is no support for SSH
29 1) with all of the key exchanges, ciphers, and compression of libssh2.
30
31 %description -l pl.UTF-8
32 Net::SSH to perlowy interfejs do biblioteki libssh2
33 (http://www.libssh2.org/). Obsługuje protokół SSH 2 (nie ma obsługi
34 SSH 1), w tym wymianę kluczy, szyfry i kompresję z libssh2.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README example/read.pl
58 %{perl_vendorarch}/Net/SSH2.pm
59 %{perl_vendorarch}/Net/SSH2
60 %dir %{perl_vendorarch}/auto/Net/SSH2
61 %attr(755,root,root) %{perl_vendorarch}/auto/Net/SSH2/SSH2.so
62 %{_mandir}/man3/Net::SSH2*.3pm*
This page took 0.073889 seconds and 4 git commands to generate.