]> git.pld-linux.org Git - packages/perl-Net-SSH2.git/blob - perl-Net-SSH2.spec
d25c105466a37aa0c3b2d199376fa577b3610635
[packages/perl-Net-SSH2.git] / perl-Net-SSH2.spec
1 #
2 # Conditional build:
3 %bcond_without  tests # do not perform "make test"
4
5 %define         pdir    Net
6 %define         pnam    SSH2
7 Summary:        Net::SSH2 Perl module - support for the SSH 2 protocol via libssh2
8 Summary(pl.UTF-8):      Moduł Perla Net::SSH2 - obsługa protokołu SSH 2 poprzez libssh2
9 Name:           perl-Net-SSH2
10 Version:        0.69
11 Release:        7
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  94ed21d4557a6bbc3cb6bfd7c3479ef0
17 URL:            http://search.cpan.org/dist/Net-SSH2/
18 BuildRequires:  libssh2-devel >= 1.7.0
19 BuildRequires:  openssl-devel
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  zlib-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Net::SSH2 is a Perl interface to the libssh2 (http://www.libssh2.org/)
27 library. It supports the SSH 2 protocol (there is no support for SSH
28 1) with all of the key exchanges, ciphers, and compression of libssh2.
29
30 %description -l pl.UTF-8
31 Net::SSH to perlowy interfejs do biblioteki libssh2
32 (http://www.libssh2.org/). Obsługuje protokół SSH 2 (nie ma obsługi
33 SSH 1), w tym wymianę kluczy, szyfry i kompresję z libssh2.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README example/read.pl
57 %{perl_vendorarch}/Net/SSH2.pm
58 %{perl_vendorarch}/Net/SSH2
59 %dir %{perl_vendorarch}/auto/Net/SSH2
60 %attr(755,root,root) %{perl_vendorarch}/auto/Net/SSH2/SSH2.so
61 %{_mandir}/man3/Net::SSH2*.3pm*
This page took 0.439143 seconds and 3 git commands to generate.