]> git.pld-linux.org Git - packages/perl-Net-SNMP.git/blob - perl-Net-SNMP.spec
- release 3: added -kill_vstring.patch
[packages/perl-Net-SNMP.git] / perl-Net-SNMP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Net
7 %define pnam    SNMP
8 Summary:        Net::SNMP - object oriented interface to SNMP
9 Summary(pl):    Net::SNMP - zorientowany obiektowo interfejs do SNMP
10 Name:           perl-Net-SNMP
11 Version:        4.1.2
12 Release:        3
13 # same as perl
14 License:        GPL or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  e6b761db6115b0b1fe5446e220abaa4a
18 Patch0:         %{name}-kill_vstring.patch
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  perl-Crypt-DES >= 2.0.3
21 BuildRequires:  perl-Digest-HMAC
22 BuildRequires:  perl-Digest-SHA1
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 Requires:       perl-Crypt-DES >= 2.0.3
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The Net::SNMP Perl module implements an object oriented interface to
30 the Simple Network Management Protocol.  Perl applications can use the
31 module to retrieve or update information on a remote host using the
32 SNMP protocol.  The module supports SNMP version-1, SNMP version-2c
33 (Community-Based SNMPv2), and SNMP version-3.  The Net::SNMP module
34 assumes that the user has a basic understanding of the Simple Network
35 Management Protocol and related network management concepts.
36
37 %description -l pl
38 Modu³ Perla Net::SNMP stanowi zorientowan± obiektowo implementacjê
39 interfejsu do protoko³u SNMP (Simple Network Management Protocol).
40 Programy perlowe mog± korzystaæ z tego modu³u do pobierania i
41 aktualizacji informacji na zdalnych hostach u¿ywaj±c protoko³u SNMP.
42 Modu³ ten obs³uguje wersje protoko³u SNMP: 1, 2c (Community-Based
43 SNMPv2) oraz 3. Modu³ Net::SNMP zak³ada, ¿e u¿ytkownik rozumie w
44 podstawowym zakresie protokó³ SNMP i zwi±zane z nim idee zarz±dzania
45 sieciowego.
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49 %patch0 -p0
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc README* Changes
70 %attr(755,root,root) %{_bindir}/*
71 %{perl_vendorlib}/Net/*.pm
72 %{perl_vendorlib}/Net/SNMP
73 %{_mandir}/man?/*
This page took 0.069318 seconds and 3 git commands to generate.