]> git.pld-linux.org Git - packages/perl-Net-SNMP.git/blob - perl-Net-SNMP.spec
- up to 6.0.1
[packages/perl-Net-SNMP.git] / perl-Net-SNMP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Net
6 %define         pnam    SNMP
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Net::SNMP - object oriented interface to SNMP
9 Summary(pl.UTF-8):      Net::SNMP - zorientowany obiektowo interfejs do SNMP
10 Name:           perl-Net-SNMP
11 Version:        6.0.1
12 Release:        1
13 # same as perl
14 License:        GPL or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://search.cpan.org/CPAN/authors/id/D/DT/DTOWN/%{pdir}-%{pnam}-v%{version}.tar.gz
17 # Source0-md5:  6137f04f9942d703f66179f890e3d096
18 Patch0:         %{name}-kill_vstring.patch
19 URL:            http://search.cpan.org/dist/Net-SNMP/
20 BuildRequires:  perl-Crypt-DES >= 2.0.3
21 BuildRequires:  perl-Digest-HMAC
22 BuildRequires:  perl-Digest-SHA1
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 Requires:       perl-Crypt-DES >= 2.0.3
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 # optional (not required if not using v6)
30 %define         _noautoreq      perl(Socket6) perl(IO::Socket::INET6)
31
32 %description
33 The Net::SNMP Perl module implements an object oriented interface to
34 the Simple Network Management Protocol. Perl applications can use the
35 module to retrieve or update information on a remote host using the
36 SNMP protocol. The module supports SNMP version-1, SNMP version-2c
37 (Community-Based SNMPv2), and SNMP version-3. The Net::SNMP module
38 assumes that the user has a basic understanding of the Simple Network
39 Management Protocol and related network management concepts.
40
41 %description -l pl.UTF-8
42 Moduł Perla Net::SNMP stanowi zorientowaną obiektowo implementację
43 interfejsu do protokołu SNMP (Simple Network Management Protocol).
44 Programy perlowe mogą korzystać z tego modułu do pobierania i
45 aktualizacji informacji na zdalnych hostach używając protokołu SNMP.
46 Moduł ten obsługuje wersje protokołu SNMP: 1, 2c (Community-Based
47 SNMPv2) oraz 3. Moduł Net::SNMP zakłada, że użytkownik rozumie w
48 podstawowym zakresie protokół SNMP i związane z nim idee zarządzania
49 sieciowego.
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-v%{version}
53 %patch0 -p1
54
55 %build
56 %{__perl} Makefile.PL \
57         INSTALLDIRS=vendor
58 %{__make}
59
60 %{?with_tests:%{__make} test}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 %{__make} install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
68 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc README Changes
76 %attr(755,root,root) %{_bindir}/snmpkey
77 %{perl_vendorlib}/Net/*.pm
78 %{perl_vendorlib}/Net/SNMP
79 %{_mandir}/man1/snmpkey.1p*
80 %{_mandir}/man3/Net::SNMP.3pm*
81 %{_examplesdir}/%{name}-%{version}
This page took 0.052815 seconds and 3 git commands to generate.