]> git.pld-linux.org Git - packages/perl-Net-RBLClient.git/blob - perl-Net-RBLClient.spec
- new
[packages/perl-Net-RBLClient.git] / perl-Net-RBLClient.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Net
7 %define pnam    RBLClient
8 Summary:        Net::RBLClient - Queries multiple Realtime Blackhole Lists in parallel
9 #Summary(pl):   
10 Name:           perl-Net-RBLClient
11 Version:        0.2
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  4691f4a80b31c83491dcbc53fc4c1e02
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module is used to discover what RBL's are listing a particular
25 IP address.  It parallelizes requests for fast response.
26
27 An RBL, or Realtime Blackhole List, is a list of IP addresses meeting
28 some criteria such as involvement in Unsolicited Bulk Email.  Each RBL
29 has its own criteria for addition and removal of addresses.  If you
30 want to block email or other traffic to/from your network based on one
31 or more RBL's, you should carefully study the behavior of those RBL's
32 before and during such blocking.
33
34 # %description -l pl
35 # TODO
36
37 %prep
38 %setup -q -n RBLCLient-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc README
59 %{perl_vendorlib}/Net/*.pm
60 %{_mandir}/man3/*
This page took 0.080017 seconds and 3 git commands to generate.