]> git.pld-linux.org Git - packages/perl-Net-Pcap.git/blob - perl-Net-Pcap.spec
- tabs in preamble
[packages/perl-Net-Pcap.git] / perl-Net-Pcap.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (require root privilleges)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Net
7 %define         pnam    Pcap
8
9 Summary:        Net::Pcap - Perl binding to the LBL pcap(3) packet capture library
10 Summary(pl.UTF-8):      Net::Pcap - dowiązanie Perla do biblioteki przechwytywania pakietów LBL pcap(3)
11 Name:           perl-Net-Pcap
12 Version:        0.12
13 Release:        0.1
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  b7a9c6be225dce74d560e109d9b702b5
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  libpcap-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The Net::Pcap module is a Perl binding to the LBL pcap(3) packet
26 capture library.
27
28 %description -l pl.UTF-8
29 Moduł Net::Pcap jest dowiązaniem Perla do biblioteki przechwytywania
30 pakietów LBL pcap(3).
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38 %{__make}
39
40 %{?with_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} install \
46         DESTDIR=$RPM_BUILD_ROOT
47 find $RPM_BUILD_ROOT -name .packlist | xargs -r rm -f
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc README
55 %attr(755,root,root) %{_bindir}/pcapinfo
56 %{perl_vendorarch}/%{pdir}/%{pnam}.pm
57 %{perl_vendorarch}/auto/%{pdir}/%{pnam}
58 %{_mandir}/man3/*
59 %{_mandir}/man1/*
This page took 0.085833 seconds and 4 git commands to generate.