]> git.pld-linux.org Git - packages/perl-Net-Pcap.git/blob - perl-Net-Pcap.spec
perl 5.38.0 rebuild
[packages/perl-Net-Pcap.git] / perl-Net-Pcap.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (require root privilleges)
4 #
5 %define         pdir    Net
6 %define         pnam    Pcap
7 Summary:        Net::Pcap - Perl binding to the LBL pcap(3) packet capture library
8 Summary(pl.UTF-8):      Net::Pcap - dowiązanie Perla do biblioteki przechwytywania pakietów LBL pcap(3)
9 Name:           perl-Net-Pcap
10 Version:        0.18
11 Release:        6
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  18d7298dca72b53271d68646c34b6a39
17 Patch0:         libpcap-1.9.patch
18 Patch1:         %{name}-signals-const.patch
19 Patch2:         %{name}-perl_settings.patch
20 URL:            http://search.cpan.org/dist/Net-Pcap/
21 BuildRequires:  libpcap-devel >= 1.9.0
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The Net::Pcap module is a Perl binding to the LBL pcap(3) packet
28 capture library.
29
30 %description -l pl.UTF-8
31 Moduł Net::Pcap jest dowiązaniem Perla do biblioteki przechwytywania
32 pakietów LBL pcap(3).
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36 %patch0 -p1
37 %patch1 -p1
38 %patch2 -p1
39
40 %build
41 %{__perl} Makefile.PL \
42         CCFLAGS="%{rpmcflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64" \
43         INSTALLDIRS=vendor
44
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54 find $RPM_BUILD_ROOT -name .packlist | xargs -r rm -f
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %attr(755,root,root) %{_bindir}/pcapinfo
63 %{perl_vendorarch}/Net/Pcap.pm
64 %dir %{perl_vendorarch}/auto/Net/Pcap
65 %attr(755,root,root) %{perl_vendorarch}/auto/Net/Pcap/Pcap.so
66 %{_mandir}/man1/pcapinfo.1p*
67 %{_mandir}/man3/Net::Pcap.3pm*
This page took 0.356408 seconds and 4 git commands to generate.