]> git.pld-linux.org Git - packages/perl-Net-Patricia.git/blob - perl-Net-Patricia.spec
- rel 4
[packages/perl-Net-Patricia.git] / perl-Net-Patricia.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Net
7 %define         pnam    Patricia
8 Summary:        Net::Patricia - Patricia Trie Perl module for fast IP address lookups
9 Summary(pl.UTF-8):      Net::Patricia - moduł Perla Patricia Trie do szybkiego wyszukiwania adresów IP
10 Name:           perl-Net-Patricia
11 Version:        1.15
12 Release:        4
13 License:        GPL v2+
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  c068c3e061cca7fc6c721e56930465f8
17 URL:            http://search.cpan.org/dist/Net-Patricia/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This module uses a Patricia Trie data structure to quickly perform IP
24 address prefix matching for applications such as IP subnet, network or
25 routing table lookups.
26
27 The data structure is based on a radix tree using a radix of two,
28 so sometimes you see patricia implementations called "radix" as well.
29 The term "Trie" is derived from the word "retrieval" but is pronounced
30 like "try".  Patricia stands for "Practical Algorithm to Retrieve
31 Information Coded as Alphanumeric", and was first suggested for
32 routing table lookups by Van Jacobsen. Patricia Trie performance
33 characteristics are well-known as it has been employed for routing
34 table lookups within the BSD kernel since the 4.3 Reno release.
35
36 %description -l pl.UTF-8
37 Ten moduł używa struktury danych Patricia Trie do wykonywania
38 szybkiego dopasowywania prefiksów IP dla zastosowań takich jak
39 przeszukiwanie podsieci IP, sieci czy tabel routingu.
40
41 Struktura danych jest oparta na drzewie radix przy podstawie
42 wynoszącej 2 - implementacje patricia czasem są nazywane także radix.
43 Termin "Trie" pochodzi od słowa "retrieval" (odczytywanie), ale jest
44 wymawiany jak "try". Patricia to skrót od "Practical Algorithm to
45 Retrieve Information Coded as Alphanumeric" (praktyczny algorytm
46 odczytywania informacji zakodowanych alfanumerycznie) i jako
47 pierwszy zaproponowany do przeszukiwania tabel routingu przez Van
48 Jacobsena. Charakterystyki wydajności Patricia Trie są dobrze znane,
49 jako że struktura ta jest wykorzystywana przy przeszukiwaniu tabel
50 routingu w jądrze BSD od wersji 4.3 Reno.
51
52 %prep
53 %setup -q -n %{pdir}-%{pnam}-%{version}
54
55 %build
56 %{__perl} Makefile.PL \
57         INSTALLDIRS=vendor
58 %{__make} \
59         CC="%{__cc}" \
60         OPTIMIZE="%{rpmcflags}"
61
62 %{?with_tests:%{__make} test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc Changes README
76 %{perl_vendorarch}/Net/*.pm
77 %dir %{perl_vendorarch}/auto/Net/Patricia
78 %{perl_vendorarch}/auto/Net/Patricia/Patricia.bs
79 %attr(755,root,root) %{perl_vendorarch}/auto/Net/Patricia/Patricia.so
80 %{_mandir}/man3/*
This page took 0.062047 seconds and 3 git commands to generate.