]> git.pld-linux.org Git - packages/perl-Net-Patricia.git/blob - perl-Net-Patricia.spec
- rel 2
[packages/perl-Net-Patricia.git] / perl-Net-Patricia.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Net
7 %define         pnam    Patricia
8 Summary:        Net::Patricia - Patricia Trie Perl module for fast IP address lookups
9 Summary(pl.UTF-8):      Net::Patricia - moduł Perla Patricia Trie do szybkiego wyszukiwania adresów IP
10 Name:           perl-Net-Patricia
11 Version:        1.014
12 Release:        2
13 License:        GPL v2+
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  16ec73b5b514dbe4275e349fca236c49
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This module uses a Patricia Trie data structure to quickly perform IP
23 address prefix matching for applications such as IP subnet, network or
24 routing table lookups.
25
26 The data structure is based on a radix tree using a radix of two,
27 so sometimes you see patricia implementations called "radix" as well.
28 The term "Trie" is derived from the word "retrieval" but is pronounced
29 like "try".  Patricia stands for "Practical Algorithm to Retrieve
30 Information Coded as Alphanumeric", and was first suggested for
31 routing table lookups by Van Jacobsen. Patricia Trie performance
32 characteristics are well-known as it has been employed for routing
33 table lookups within the BSD kernel since the 4.3 Reno release.
34
35 %description -l pl.UTF-8
36 Ten moduł używa struktury danych Patricia Trie do wykonywania
37 szybkiego dopasowywania prefiksów IP dla zastosowań takich jak
38 przeszukiwanie podsieci IP, sieci czy tabel routingu.
39
40 Struktura danych jest oparta na drzewie radix przy podstawie
41 wynoszącej 2 - implementacje patricia czasem są nazywane także radix.
42 Termin "Trie" pochodzi od słowa "retrieval" (odczytywanie), ale jest
43 wymawiany jak "try". Patricia to skrót od "Practical Algorithm to
44 Retrieve Information Coded as Alphanumeric" (praktyczny algorytm
45 odczytywania informacji zakodowanych alfanumerycznie) i jako
46 pierwszy zaproponowany do przeszukiwania tabel routingu przez Van
47 Jacobsena. Charakterystyki wydajności Patricia Trie są dobrze znane,
48 jako że struktura ta jest wykorzystywana przy przeszukiwaniu tabel
49 routingu w jądrze BSD od wersji 4.3 Reno.
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-%{version}
53
54 %build
55 %{__perl} Makefile.PL \
56         INSTALLDIRS=vendor
57 %{__make} \
58         CC="%{__cc}" \
59         OPTIMIZE="%{rpmcflags}"
60
61 %{?with_tests:%{__make} test}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc Changes README
75 %{perl_vendorarch}/Net/*.pm
76 %dir %{perl_vendorarch}/auto/Net/Patricia
77 %{perl_vendorarch}/auto/Net/Patricia/Patricia.bs
78 %attr(755,root,root) %{perl_vendorarch}/auto/Net/Patricia/Patricia.so
79 %{_mandir}/man3/*
This page took 0.107723 seconds and 3 git commands to generate.