]> git.pld-linux.org Git - packages/perl-Net-Patricia.git/blob - perl-Net-Patricia.spec
- rel 2
[packages/perl-Net-Patricia.git] / perl-Net-Patricia.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Net
7 %define         pnam    Patricia
8 Summary:        Net::Patricia - Patricia Trie Perl module for fast IP address lookups
9 Summary(pl.UTF-8):      Net::Patricia - moduł Perla Patricia Trie do szybkiego wyszukiwania adresów IP
10 Name:           perl-Net-Patricia
11 Version:        1.20
12 Release:        2
13 License:        GPL v2+
14 Group:          Development/Languages/Perl
15 Source0:        http://search.cpan.org/CPAN/authors/id/G/GR/GRUBER/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d5499f5bc1d6c36538a84153095ea11f
17 URL:            http://search.cpan.org/dist/Net-Patricia/
18 BuildRequires:  perl-Net-CIDR-Lite
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module uses a Patricia Trie data structure to quickly perform IP
25 address prefix matching for applications such as IP subnet, network or
26 routing table lookups.
27
28 The data structure is based on a radix tree using a radix of two,
29 so sometimes you see patricia implementations called "radix" as well.
30 The term "Trie" is derived from the word "retrieval" but is pronounced
31 like "try".  Patricia stands for "Practical Algorithm to Retrieve
32 Information Coded as Alphanumeric", and was first suggested for
33 routing table lookups by Van Jacobsen. Patricia Trie performance
34 characteristics are well-known as it has been employed for routing
35 table lookups within the BSD kernel since the 4.3 Reno release.
36
37 %description -l pl.UTF-8
38 Ten moduł używa struktury danych Patricia Trie do wykonywania
39 szybkiego dopasowywania prefiksów IP dla zastosowań takich jak
40 przeszukiwanie podsieci IP, sieci czy tabel routingu.
41
42 Struktura danych jest oparta na drzewie radix przy podstawie
43 wynoszącej 2 - implementacje patricia czasem są nazywane także radix.
44 Termin "Trie" pochodzi od słowa "retrieval" (odczytywanie), ale jest
45 wymawiany jak "try". Patricia to skrót od "Practical Algorithm to
46 Retrieve Information Coded as Alphanumeric" (praktyczny algorytm
47 odczytywania informacji zakodowanych alfanumerycznie) i jako
48 pierwszy zaproponowany do przeszukiwania tabel routingu przez Van
49 Jacobsena. Charakterystyki wydajności Patricia Trie są dobrze znane,
50 jako że struktura ta jest wykorzystywana przy przeszukiwaniu tabel
51 routingu w jądrze BSD od wersji 4.3 Reno.
52
53 %prep
54 %setup -q -n %{pdir}-%{pnam}-%{version}
55
56 %build
57 %{__perl} Makefile.PL \
58         INSTALLDIRS=vendor
59 %{__make} \
60         CC="%{__cc}" \
61         OPTIMIZE="%{rpmcflags}"
62
63 %{?with_tests:%{__make} test}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %{__make} install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc Changes README
77 %{perl_vendorarch}/Net/*.pm
78 %dir %{perl_vendorarch}/auto/Net/Patricia
79 %{perl_vendorarch}/auto/Net/Patricia/Patricia.bs
80 %attr(755,root,root) %{perl_vendorarch}/auto/Net/Patricia/Patricia.so
81 %{_mandir}/man3/*
This page took 0.031701 seconds and 3 git commands to generate.