]> git.pld-linux.org Git - packages/perl-Net-DNS.git/blob - perl-Net-DNS.spec
- should be ready for perl-5.8.0; release++
[packages/perl-Net-DNS.git] / perl-Net-DNS.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Net
7 %define pnam    DNS
8 Summary:        Net::DNS - Perl interface to the DNS resolver
9 Summary(pl):    Net::DNS - interfejs do resolvera DNS
10 Name:           perl-Net-DNS
11 Version:        0.33
12 Release:        2
13 License:        GPL/Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 BuildRequires:  perl >= 5.6
17 %if %{?_without_tests:0}%{!?_without_tests:1}
18 BuildRequires:  perl-Digest-MD5 >= 2.12
19 BuildRequires:  perl-Digest-HMAC >= 1.00
20 BuildRequires:  perl-MIME-Base64 >= 2.11
21 BuildRequires:  perl-Test-Simple >= 0.18
22 %endif
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Net::DNS is a DNS resolver implemented in Perl. It allows the
29 programmer to perform nearly any type of DNS query from a Perl script.
30
31 %description -l pl
32 Net::DNS jest resolverem DNS, zaimplementowanym w Perlu. Pozwala
33 programi¶cie na wykonanie niemal ka¿dego typu zapytania DNS ze skryptu
34 Perla.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor 
42 %{__make}
43
44 %{!?_without_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
49
50 %{__make} install DESTDIR=$RPM_BUILD_ROOT
51
52 install demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53 cp -a contrib $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README TODO
61 %{perl_vendorlib}/Net/DNS.pm
62 %{perl_vendorlib}/Net/DNS
63 %{_mandir}/man3/*
64 %{_examplesdir}/%{name}-%{version}
This page took 0.06639 seconds and 4 git commands to generate.