]> git.pld-linux.org Git - packages/perl-Net-DNS.git/blob - perl-Net-DNS.spec
- updated to 0.40
[packages/perl-Net-DNS.git] / perl-Net-DNS.spec
1 #
2 # Conditional build:
3 # _without_tests        - do not perform "make test"
4 # _with_libresolv       - link against libresolv
5 #
6 %include        /usr/lib/rpm/macros.perl
7 %define pdir    Net
8 %define pnam    DNS
9 Summary:        Net::DNS - Perl interface to the DNS resolver
10 Summary(pl):    Net::DNS - interfejs do resolvera DNS
11 Name:           perl-Net-DNS
12 Version:        0.40
13 Release:        1
14 License:        GPL/Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  4e5b9e53387638aeb5254b5537942c23
18 BuildRequires:  perl-devel >= 5.6
19 %if %{?_without_tests:0}%{!?_without_tests:1}
20 BuildRequires:  perl-Digest-MD5 >= 2.12
21 BuildRequires:  perl-Digest-HMAC >= 1.00
22 BuildRequires:  perl-MIME-Base64 >= 2.11
23 BuildRequires:  perl-Test-Simple >= 0.18
24 %endif
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 %if %{?_with_libresolv:0}%{!?_with_libresolv:1}
27 BuildArch:      noarch
28 %endif
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Net::DNS is a DNS resolver implemented in Perl. It allows the
33 programmer to perform nearly any type of DNS query from a Perl script.
34
35 %description -l pl
36 Net::DNS jest resolverem DNS, zaimplementowanym w Perlu. Pozwala
37 programi¶cie na wykonanie niemal ka¿dego typu zapytania DNS ze skryptu
38 Perla.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL </dev/null \
45         %{?_with_libresolv:     --xs} \
46         %{?!_with_libresolv:    --pm} \
47         INSTALLDIRS=vendor
48
49 %{__make} %{?_with_libresolv: OPTIMIZE="%{rpmcflags}"}
50
51 %{!?_without_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56
57 %{__make} install DESTDIR=$RPM_BUILD_ROOT
58
59 install demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60 cp -a contrib $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Changes README TODO
68 %if 0%{?_with_libresolv:1}
69 %{perl_vendorarch}/Net/DNS.pm
70 %{perl_vendorarch}/Net/DNS
71 %{perl_vendorarch}/auto/Net/DNS/DNS.bs
72 %attr(755,root,root) %{perl_vendorarch}/auto/Net/DNS/DNS.so
73 %else
74 %{perl_vendorlib}/Net/DNS.pm
75 %{perl_vendorlib}/Net/DNS
76 %endif
77
78
79 %{_mandir}/man3/*
80 %{_examplesdir}/%{name}-%{version}
This page took 0.851182 seconds and 4 git commands to generate.