]> git.pld-linux.org Git - packages/perl-Net-DNS.git/blob - perl-Net-DNS.spec
- up to 0.41
[packages/perl-Net-DNS.git] / perl-Net-DNS.spec
1
2 # Conditional build:
3 %bcond_without tests    # do not perform "make test"
4 # link against libresolv (creates architecture-dependent package)
5 %bcond_with libresolv   
6
7 %include        /usr/lib/rpm/macros.perl
8 %define pdir    Net
9 %define pnam    DNS
10 Summary:        Net::DNS - Perl interface to the DNS resolver
11 Summary(pl):    Net::DNS - interfejs do resolvera DNS
12 Name:           perl-Net-DNS
13 Version:        0.41
14 Release:        1
15 License:        GPL/Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  e766ff5b707f562a05c42a7cd8491852
19 BuildRequires:  perl-devel >= 5.6
20 %if %{with tests}
21 BuildRequires:  perl-Digest-MD5 >= 2.12
22 BuildRequires:  perl-Digest-HMAC >= 1.00
23 BuildRequires:  perl-MIME-Base64 >= 2.11
24 BuildRequires:  perl-Test-Simple >= 0.18
25 BuildRequires:  perl-Test-Pod >= 0.95
26 %endif
27 BuildRequires:  rpm-perlprov >= 4.1-13
28 %if !%{with libresolv}
29 BuildArch:      noarch
30 %endif
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Net::DNS is a DNS resolver implemented in Perl. It allows the
35 programmer to perform nearly any type of DNS query from a Perl script.
36
37 %description -l pl
38 Net::DNS jest resolverem DNS, zaimplementowanym w Perlu. Pozwala
39 programi¶cie na wykonanie niemal ka¿dego typu zapytania DNS ze skryptu
40 Perla.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL </dev/null \
47         %{?with_libresolv:      --xs} \
48         %{!?_with_libresolv:    --pm} \
49         INSTALLDIRS=vendor
50
51 %{__make} \
52         %{?with_libresolv: OPTIMIZE="%{rpmcflags}"}
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 install demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64 cp -a contrib $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc Changes README TODO
72 %if %{with libresolv}
73 %{perl_vendorarch}/Net/DNS.pm
74 %{perl_vendorarch}/Net/DNS
75 %{perl_vendorarch}/auto/Net/DNS/DNS.bs
76 %attr(755,root,root) %{perl_vendorarch}/auto/Net/DNS/DNS.so
77 %else
78 %{perl_vendorlib}/Net/DNS.pm
79 %{perl_vendorlib}/Net/DNS
80 %endif
81
82 %{_mandir}/man3/*
83 %{_examplesdir}/%{name}-%{version}
This page took 0.078165 seconds and 4 git commands to generate.