]> git.pld-linux.org Git - packages/perl-Net-DNS.git/blob - perl-Net-DNS.spec
- rel 2, fix unreachable ns problem
[packages/perl-Net-DNS.git] / perl-Net-DNS.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 %include        /usr/lib/rpm/macros.perl
5 %define pdir    Net
6 %define pnam    DNS
7 Summary:        Net::DNS - Perl interface to the DNS resolver.
8 Summary(pl):    Net::DNS - interfejs do resolvera DNS.
9 Name:           perl-Net-DNS
10 Version:        0.28
11 Release:        2
12 License:        GPL/Artistic
13 Group:          Development/Languages/Perl
14 Source0:        ftp://ftp.cpan.org/pub/CPAN/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 Patch0:         %{name}-unreachable_ns.patch
16 BuildRequires:  perl >= 5.6
17 %if %{?_without_tests:0}%{!?_without_tests:1}
18 BuildRequires:  perl-Digest-MD5 >= 2.12
19 BuildRequires:  perl-Digest-HMAC >= 1.00
20 BuildRequires:  perl-MIME-Base64 >= 2.11
21 BuildRequires:  perl-Test-Simple >= 0.18
22 %endif
23 BuildRequires:  rpm-perlprov >= 3.0.3-16
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Net::DNS is a DNS resolver implemented in Perl.  It allows the programmer
29 to perform nearly any type of DNS query from a Perl script.
30
31 %description -l pl
32 Net::DNS jest resolverem DNS, zaimplementowanym w Perlu.  Pozwala
33 programi¶cie na wykonanie niemal ka¿dego typu zapytania DNS ze skryptu
34 Perla.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38 %patch0 -p1
39
40 %build
41 perl Makefile.PL
42 %{__make}
43
44 %{!?_without_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
49
50 %{__make} install DESTDIR=$RPM_BUILD_ROOT
51
52 install demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53 cp -a contrib $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README TODO
61 %{perl_sitelib}/Net/DNS.pm
62 %{perl_sitelib}/Net/DNS
63 %{_mandir}/man3/*
64 %{_examplesdir}/%{name}-%{version}
This page took 0.031978 seconds and 4 git commands to generate.