]> git.pld-linux.org Git - packages/perl-Net-DNS.git/blob - perl-Net-DNS.spec
- up to 0.51
[packages/perl-Net-DNS.git] / perl-Net-DNS.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 %bcond_with     libresolv       # link against libresolv (creates architecture-dependent package)
5 #
6 %include        /usr/lib/rpm/macros.perl
7 %define         pdir    Net
8 %define         pnam    DNS
9 Summary:        Net::DNS - Perl interface to the DNS resolver
10 Summary(pl):    Net::DNS - interfejs perlowy do resolvera DNS
11 Name:           perl-Net-DNS
12 Version:        0.51
13 Release:        1
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  fc358c06e65b1918b93e1a92e02065b8
19 BuildRequires:  perl-devel >= 1:5.8.0
20 %if %{with tests}
21 BuildRequires:  perl-Digest-MD5 >= 2.12
22 BuildRequires:  perl-Digest-HMAC >= 1.00
23 BuildRequires:  perl-MIME-Base64 >= 2.11
24 BuildRequires:  perl-Test-Simple >= 0.18
25 BuildRequires:  perl-Test-Pod >= 0.95
26 %endif
27 BuildRequires:  rpm-perlprov >= 4.1-13
28 %if !%{with libresolv}
29 BuildArch:      noarch
30 %endif
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Net::DNS is a DNS resolver implemented in Perl. It allows the
35 programmer to perform nearly any type of DNS query from a Perl script.
36
37 %description -l pl
38 Net::DNS jest resolverem DNS, zaimplementowanym w Perlu. Pozwala
39 programi¶cie na wykonanie niemal ka¿dego typu zapytania DNS ze skryptu
40 Perla.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL </dev/null \
47         %{?with_libresolv:      --xs} \
48         %{!?with_libresolv:     --no-xs} \
49         --no-online-tests \
50         INSTALLDIRS=vendor
51 %{__make} \
52         %{?with_libresolv: OPTIMIZE="%{rpmcflags}"}
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62 install demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
63 cp -a contrib $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64
65 # get rid of pod documentation
66 %if %{with libresolv}
67 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/Net/DNS/*.pod
68 %else
69 rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/Net/DNS/*.pod
70 %endif
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc Changes README TODO
78 %if %{with libresolv}
79 %{perl_vendorarch}/Net/DNS.pm
80 %{perl_vendorarch}/Net/DNS
81 %{perl_vendorarch}/auto/Net/DNS/DNS.bs
82 %attr(755,root,root) %{perl_vendorarch}/auto/Net/DNS/DNS.so
83 %else
84 %{perl_vendorlib}/Net/DNS.pm
85 %{perl_vendorlib}/Net/DNS
86 %endif
87
88 %{_mandir}/man3/*
89 %{_examplesdir}/%{name}-%{version}
This page took 0.084666 seconds and 4 git commands to generate.