]> git.pld-linux.org Git - packages/perl-Net-DNS.git/blob - perl-Net-DNS.spec
- informative summary/description
[packages/perl-Net-DNS.git] / perl-Net-DNS.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 %include        /usr/lib/rpm/macros.perl
5 %define pdir    Net
6 %define pnam    DNS
7 Summary:        Net::DNS - Perl interface to the DNS resolver.
8 Summary(pl):    Net::DNS - interfejs do resolvera DNS.
9 Name:           perl-Net-DNS
10 Version:        0.28
11 Release:        1
12 License:        GPL/Artistic
13 Group:          Development/Languages/Perl
14 Source0:        ftp://ftp.cpan.org/pub/CPAN/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 BuildRequires:  perl >= 5.6
16 %if %{?_without_tests:0}%{!?_without_tests:1}
17 BuildRequires:  perl-Digest-MD5 >= 2.12
18 BuildRequires:  perl-Digest-HMAC >= 1.00
19 BuildRequires:  perl-MIME-Base64 >= 2.11
20 BuildRequires:  perl-Test-Simple >= 0.18
21 %endif
22 BuildRequires:  rpm-perlprov >= 3.0.3-16
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Net::DNS is a DNS resolver implemented in Perl.  It allows the programmer
28 to perform nearly any type of DNS query from a Perl script.
29
30 %description -l pl
31 Net::DNS jest resolverem DNS, zaimplementowanym w Perlu.  Pozwala
32 programi¶cie na wykonanie niemal ka¿dego typu zapytania DNS ze skryptu
33 Perla.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 perl Makefile.PL
40 %{__make}
41
42 %{!?_without_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
47
48 %{__make} install DESTDIR=$RPM_BUILD_ROOT
49
50 install demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
51 cp -a contrib $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README TODO
59 %{perl_sitelib}/Net/DNS.pm
60 %{perl_sitelib}/Net/DNS
61 %{_mandir}/man3/*
62 %{_examplesdir}/%{name}-%{version}
This page took 0.030572 seconds and 4 git commands to generate.