]> git.pld-linux.org Git - packages/perl-Net-DNS.git/blob - perl-Net-DNS.spec
- massive attack: source-md5
[packages/perl-Net-DNS.git] / perl-Net-DNS.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Net
7 %define pnam    DNS
8 Summary:        Net::DNS - Perl interface to the DNS resolver
9 Summary(pl):    Net::DNS - interfejs do resolvera DNS
10 Name:           perl-Net-DNS
11 Version:        0.34
12 Release:        1
13 License:        GPL/Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  ef979460d952665f67d2c8474763156e
17 BuildRequires:  perl-devel >= 5.6
18 %if %{?_without_tests:0}%{!?_without_tests:1}
19 BuildRequires:  perl-Digest-MD5 >= 2.12
20 BuildRequires:  perl-Digest-HMAC >= 1.00
21 BuildRequires:  perl-MIME-Base64 >= 2.11
22 BuildRequires:  perl-Test-Simple >= 0.18
23 %endif
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Net::DNS is a DNS resolver implemented in Perl. It allows the
30 programmer to perform nearly any type of DNS query from a Perl script.
31
32 %description -l pl
33 Net::DNS jest resolverem DNS, zaimplementowanym w Perlu. Pozwala
34 programi¶cie na wykonanie niemal ka¿dego typu zapytania DNS ze skryptu
35 Perla.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} -MExtUtils::MakeMaker -e 'WriteMakefile(NAME=>"Net::DNS")' \
42         INSTALLDIRS=vendor 
43 %{__make}
44
45 %{!?_without_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
50
51 %{__make} install DESTDIR=$RPM_BUILD_ROOT
52
53 install demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54 cp -a contrib $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README TODO
62 %{perl_vendorlib}/Net/DNS.pm
63 %{perl_vendorlib}/Net/DNS
64 %{_mandir}/man3/*
65 %{_examplesdir}/%{name}-%{version}
This page took 0.029154 seconds and 3 git commands to generate.