]> git.pld-linux.org Git - packages/perl-Net-BGP.git/blob - perl-Net-BGP.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Net-BGP.git] / perl-Net-BGP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Net
6 %define         pnam    BGP
7 Summary:        Net::BGP - Border Gateway Protocol version 4 speaker/listener library
8 Summary(pl.UTF-8):      Net::BGP - biblioteka obsługująca Border Gateway Protocol w wersji 4
9 Name:           perl-Net-BGP
10 Version:        0.14
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  1a6c537a1b457f9ebf0bec1ce79c3d71
17 URL:            http://search.cpan.org/dist/Net-BGP/
18 %if %{with tests}
19 BuildRequires:  perl(List::Util) >= 1.01
20 BuildRequires:  perl-Test-Harness >= 2.00
21 BuildRequires:  perl-Test-Simple >= 0.47
22 %endif
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module is an implementation of the BGP-4 inter-domain routing
30 protocol. It encapsulates all of the functionality needed to establish
31 and maintain a BGP peering session and exchange routing update
32 information with the peer. It aims to provide a simple API to the BGP
33 protocol for the purposes of automation, logging, monitoring, testing,
34 and similar tasks using the power and flexibility of Perl. The module
35 does not implement the functionality of a RIB (Routing Information
36 Base) nor does it modify the kernel routing table of the host system.
37 However, such operations could be implemented using the API provided
38 by the module.
39
40 %description -l pl.UTF-8
41 Ten moduł jest implementacją protokołu routingu międzydomenowego
42 BGP-4. Zawiera on całą funkcjonalność potrzebną do ustanowienia i
43 zarządzania sesją BGP oraz wymiany informacji o uaktualnieniach
44 routingu z drugą stroną. Celem jest dostarczenie prostego API do
45 protokołu BGP do celów automatyzacji, logowania, monitorowania,
46 testowania i podobnych zadań z użyciem potęgi i elastyczności Perla.
47 Moduł nie zawiera implementacji RIB (Routing Information Base) ani
48 nie modyfikuje tablicy routingu w jądrze systemu, jednak takie
49 operacje mogą być zaimplementowane przy użyciu API dostarczonego
50 przez ten moduł.
51
52 %prep
53 %setup -q -n %{pdir}-%{pnam}-%{version}
54 mv t/00-Signature.t{,.blah}
55
56 %build
57 %{__perl} Makefile.PL \
58         INSTALLDIRS=vendor
59 %{__make}
60
61 %{?with_tests:%{__make} test}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc Changes README
75 %{perl_vendorlib}/Net/BGP.pm
76 %{perl_vendorlib}/Net/BGP
77 %{_mandir}/man3/*
This page took 0.123713 seconds and 4 git commands to generate.