]> git.pld-linux.org Git - packages/perl-Monitoring-Plugin.git/blob - perl-Nagios-Plugin.spec
- use base ... not catched by perl autodeps
[packages/perl-Monitoring-Plugin.git] / perl-Nagios-Plugin.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Nagios
7 %define pnam    Plugin
8 Summary:        Nagios::Plugin - A family of perl modules to streamline writing Nagios plugins
9 Name:           perl-Nagios-Plugin
10 Version:        0.23
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/T/TO/TONVOON/Nagios-Plugin-%{version}.tar.gz
16 # Source0-md5:  7eb466f122ea83788506d78d7bf2c402
17 URL:            http://search.cpan.org/dist/Nagios-Plugin/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Class::Accessor)
22 BuildRequires:  perl(Config::Tiny)
23 BuildRequires:  perl(Math::Calc::Units)
24 BuildRequires:  perl(Params::Validate)
25 BuildRequires:  perl(Test::More) >= 0.62
26 %endif
27 # Not catched by `use base qw(Class::Accessor::Fast)'; construct
28 Requires:       perl-Class-Accessor
29 Requires:       perl-Config-Tiny
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Nagios::Plugin and its associated Nagios::Plugin::* modules are a
35 family of Perl modules to streamline writing Nagios plugins. The main
36 end user modules are Nagios::Plugin, providing an object-oriented
37 interface to the entire Nagios::Plugin::* collection, and
38 Nagios::Plugin::Functions, providing a simpler functional interface to
39 a useful subset of the available functionality.
40
41 The purpose of the collection is to make it as simple as possible for
42 developers to create plugins that conform the Nagios Plugin guidelines
43 <http://nagiosplug.sourceforge.net/developer-guidelines.html>.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make}
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes README
67 %dir %{perl_vendorlib}/Nagios
68 %{perl_vendorlib}/Nagios/*.pm
69 %{perl_vendorlib}/Nagios/Plugin
70 %{_mandir}/man3/*
This page took 0.148398 seconds and 3 git commands to generate.