]> git.pld-linux.org Git - packages/perl-Mouse.git/blob - perl-Mouse.spec
- rebuild with perl 5.26
[packages/perl-Mouse.git] / perl-Mouse.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Mouse
7 Summary:        Mouse - Moose minus the antlers
8 Name:           perl-Mouse
9 Version:        2.4.5
10 Release:        3
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://search.cpan.org/CPAN/authors/id/S/SY/SYOHEX/%{pdir}-v%{version}.tar.gz
15 # Source0-md5:  2183f5bc16c7d37df5cf1dacf8ef88a1
16 URL:            http://search.cpan.org/dist/Mouse/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRequires:  perl-Module-Build-XSUtil
20 %if %{with tests}
21 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.42
22 BuildRequires:  perl-Test-Exception >= 0.21
23 BuildRequires:  perl-Test-Simple >= 0.8
24 BuildRequires:  perl-Test-LeakTrace
25 %endif
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Moose is wonderful. Use Moose instead of Mouse.
30
31 Unfortunately, it's a little slow. Though significant progress has
32 been made over the years, the compile time penalty is a non-starter
33 for some applications.
34
35 Mouse aims to alleviate this by providing a subset of Moose's
36 functionality, faster. In particular, L<Moose/has> is missing only a
37 few expert-level features.
38
39 %prep
40 %setup -q -n %{pdir}-v%{version}
41
42 %build
43 %{__perl} Build.PL \
44         destdir=$RPM_BUILD_ROOT \
45         installdirs=vendor
46
47 ./Build \
48         CFLAGS="%{rpmcflags}"
49
50 %{?with_tests:./Build test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/MouseX
55
56 ./Build install
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes
64 %{perl_vendorlib}/MouseX/
65 %{perl_vendorarch}/*.pm
66 %{perl_vendorarch}/Mouse/
67 %{perl_vendorarch}/Squirrel/
68 %{perl_vendorarch}/Test/*.pm
69 %dir %{perl_vendorarch}/auto/%{pdir}
70 %attr(755,root,root) %{perl_vendorarch}/auto/%{pdir}/*.so
71 %{_mandir}/man3/*
This page took 0.052341 seconds and 4 git commands to generate.