]> git.pld-linux.org Git - packages/perl-Mouse.git/blob - perl-Mouse.spec
- new
[packages/perl-Mouse.git] / perl-Mouse.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Mouse
7 Summary:        Mouse - Moose minus the antlers
8 #Summary(pl.UTF-8):     
9 Name:           perl-Mouse
10 Version:        0.14
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/S/SA/SARTAK/Mouse-0.14.tar.gz
16 # Source0-md5:  3980508cd94135d078d70106634b8029
17 URL:            http://search.cpan.org/dist/Mouse/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Class::Method::Modifiers) >= 1.01
22 BuildRequires:  perl-MRO-Compat
23 BuildRequires:  perl-Sub-Exporter
24 BuildRequires:  perl-Test-Exception
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 L<Moose> is wonderful.
31
32 Unfortunately, it's a little slow. Though significant progress has
33 been made over the years, the compile time penalty is a non-starter
34 for some applications.
35
36 Mouse aims to alleviate this by providing a subset of Moose's
37 functionality, faster. In particular, L<Moose/has> is missing only
38 a few expert-level features.
39
40 # %description -l pl.UTF-8
41 # TODO
42
43 %prep
44 %setup -q -n %{pdir}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} pure_install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes
65 %{perl_vendorlib}/*.pm
66 %{perl_vendorlib}/Mouse/
67 %{perl_vendorlib}/MouseX/
68 %{perl_vendorlib}/Squirrel/
69 %{_mandir}/man3/*
This page took 0.052089 seconds and 4 git commands to generate.