]> git.pld-linux.org Git - packages/perl-Mouse.git/blob - perl-Mouse.spec
- rebuild with perl 5.30.0
[packages/perl-Mouse.git] / perl-Mouse.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Mouse
7 Summary:        Mouse - Moose minus the antlers
8 Name:           perl-Mouse
9 Version:        2.5.9
10 Release:        2
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://search.cpan.org/CPAN/authors/id/S/SK/SKAJI/%{pdir}-v%{version}.tar.gz
15 # Source0-md5:  ffc0f03b781a70a585097a97fe107d9f
16 URL:            http://search.cpan.org/dist/Mouse/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRequires:  perl-Module-Build-XSUtil
20 %if %{with tests}
21 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.42
22 BuildRequires:  perl-Test-Exception >= 0.21
23 BuildRequires:  perl-Test-Requires
24 BuildRequires:  perl-Test-Simple >= 0.8
25 BuildRequires:  perl-Test-LeakTrace
26 %endif
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Moose is wonderful. Use Moose instead of Mouse.
31
32 Unfortunately, it's a little slow. Though significant progress has
33 been made over the years, the compile time penalty is a non-starter
34 for some applications.
35
36 Mouse aims to alleviate this by providing a subset of Moose's
37 functionality, faster. In particular, L<Moose/has> is missing only a
38 few expert-level features.
39
40 %prep
41 %setup -q -n %{pdir}-v%{version}
42
43 %build
44 %{__perl} Build.PL \
45         destdir=$RPM_BUILD_ROOT \
46         installdirs=vendor
47
48 ./Build \
49         CFLAGS="%{rpmcflags}"
50
51 %{?with_tests:./Build test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/MouseX
56
57 ./Build install
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes
65 %{perl_vendorlib}/MouseX/
66 %{perl_vendorarch}/*.pm
67 %{perl_vendorarch}/Mouse/
68 %{perl_vendorarch}/Squirrel/
69 %{perl_vendorarch}/Test/*.pm
70 %dir %{perl_vendorarch}/auto/%{pdir}
71 %attr(755,root,root) %{perl_vendorarch}/auto/%{pdir}/*.so
72 %{_mandir}/man3/*
This page took 0.075002 seconds and 4 git commands to generate.