]> git.pld-linux.org Git - packages/perl-Mouse.git/blob - perl-Mouse.spec
- rebuild with perl 5.18.0
[packages/perl-Mouse.git] / perl-Mouse.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Mouse
7 Summary:        Mouse - Moose minus the antlers
8 #Summary(pl.UTF-8):
9 Name:           perl-Mouse
10 Version:        0.97
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://search.cpan.org/CPAN/authors/id/G/GF/GFUJI/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  92a8b387f9619d32bce6685c1dd370e5
17 URL:            http://search.cpan.org/dist/Mouse/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.42
22 BuildRequires:  perl-Test-Exception >= 0.21
23 BuildRequires:  perl-Test-Simple >= 0.8
24 %endif
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Moose is wonderful. Use Moose instead of Mouse.
29
30 Unfortunately, it's a little slow. Though significant progress has
31 been made over the years, the compile time penalty is a non-starter
32 for some applications.
33
34 Mouse aims to alleviate this by providing a subset of Moose's
35 functionality, faster. In particular, L<Moose/has> is missing only a
36 few expert-level features.
37
38 # %description -l pl.UTF-8
39
40 %prep
41 %setup -q -n %{pdir}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/MouseX
53
54 %{__make} pure_install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes
63 %{perl_vendorlib}/MouseX/
64 %{perl_vendorarch}/*.pm
65 %{perl_vendorarch}/Mouse/
66 %{perl_vendorarch}/Squirrel/
67 %{perl_vendorarch}/Test/*.pm
68 %dir %{perl_vendorarch}/auto/%{pdir}
69 %attr(755,root,root) %{perl_vendorarch}/auto/%{pdir}/*.so
70 %{_mandir}/man3/*
This page took 0.065485 seconds and 4 git commands to generate.