]> git.pld-linux.org Git - packages/perl-Mouse.git/blob - perl-Mouse.spec
- version 0.28
[packages/perl-Mouse.git] / perl-Mouse.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Mouse
7 Summary:        Mouse - Moose minus the antlers
8 #Summary(pl.UTF-8):
9 Name:           perl-Mouse
10 Version:        0.28
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://search.cpan.org/CPAN/authors/id/S/SU/SUNNAVY/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  44131d442479efe442abc713248249ae
17 URL:            http://search.cpan.org/dist/Mouse/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.42
22 BuildRequires:  perl-Test-Exception >= 0.21
23 BuildRequires:  perl-Test-Simple >= 0.8
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Moose is wonderful. Use Moose instead of Mouse.
30
31 Unfortunately, it's a little slow. Though significant progress has
32 been made over the years, the compile time penalty is a non-starter
33 for some applications.
34
35 Mouse aims to alleviate this by providing a subset of Moose's
36 functionality, faster. In particular, L<Moose/has> is missing only a
37 few expert-level features.
38
39 # %description -l pl.UTF-8
40
41 %prep
42 %setup -q -n %{pdir}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/MouseX
54
55 %{__make} pure_install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes
64 %{perl_vendorlib}/*.pm
65 %{perl_vendorlib}/Mouse/
66 %{perl_vendorlib}/MouseX/
67 %{perl_vendorlib}/Squirrel/
68 %{_mandir}/man3/*
This page took 0.062673 seconds and 4 git commands to generate.