]> git.pld-linux.org Git - packages/perl-MooseX-NonMoose.git/blob - perl-MooseX-NonMoose.spec
1c84fe58d7d36f3add594d69ee28453f24ee4bf1
[packages/perl-MooseX-NonMoose.git] / perl-MooseX-NonMoose.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    MooseX
6 %define         pnam    NonMoose
7 Summary:        MooseX::NonMoose - easy subclassing of non-Moose classes
8 Name:           perl-MooseX-NonMoose
9 Version:        0.22
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/MooseX/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  08627b8575835e64b44e82424df27a8f
16 URL:            http://search.cpan.org/dist/MooseX-NonMoose/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl(Test::Fatal)
21 BuildRequires:  perl-List-MoreUtils
22 BuildRequires:  perl-Moose >= 1.15
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 MooseX::NonMoose allows for easily subclassing non-Moose classes with
29 Moose, taking care of the annoying details connected with doing this,
30 such as setting up proper inheritance from Moose::Object and
31 installing (and inlining, at make_immutable time) a constructor that
32 makes sure things like BUILD methods are called. It tries to be as
33 non-intrusive as possible - when this module is used, inheriting from
34 non-Moose classes and inheriting from Moose classes should work
35 identically, aside from the few caveats mentioned below. One of the
36 goals of this module is that including it in a Moose::Exporter-based
37 package used across an entire application should be possible, without
38 interfering with classes that only inherit from Moose modules, or even
39 classes that don't inherit from anything at all.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} pure_install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README
63 %{perl_vendorlib}/MooseX/*.pm
64 %{perl_vendorlib}/MooseX/NonMoose
65 %{_mandir}/man3/*
This page took 0.075266 seconds and 3 git commands to generate.