]> git.pld-linux.org Git - SPECS.git/blob - perl-Module-Versions-Report.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-Module-Versions-Report.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Module
6 %define         pnam    Versions-Report
7 Summary:        Module::Versions::Report - report versions of all modules in memory
8 Summary(pl.UTF-8):      Module::Versions::Report - raportowanie wersji wszystkich modułów w pamięci
9 Name:           perl-Module-Versions-Report
10 Version:        1.06
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Module/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  9c7efaa4c3dd8eecceb8e5d17476479b
17 URL:            http://search.cpan.org/dist/Module-Versions-Report/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 I often get email from someone reporting a bug in a module I've written.
25 I email back, asking what version of the module it is, what version of
26 Perl on what OS, and sometimes what version of some relevant third library
27 (like XML::Parser). They reply, saying "Perl 5". I say "I need the exact
28 version, as reported by `perl -v`". They tell me. And I say "I, uh,
29 also asked about the version of my module and XML::Parser [or whatever]".
30 They say "Oh yeah. It's 2.27". "Is that my module or XML::Parser?"
31 "XML::Parser." "OK, and what about my module's version?" "Ohyeah.
32 That's 3.11." By this time, days have passed, and what should have been
33 a simple operation - reporting the version of Perl and relevant modules,
34 has been needlessly complicated.
35
36 This module is for simplifying that task. If you add "use
37 Module::Versions::Report;" to a program (especially handy if your program
38 is one that demonstrates a bug in some module), then when the program
39 has finished running, you well get a report detailing the all modules
40 in memory, and noting the version of each (for modules that defined a
41 $VERSION, at least).
42
43 %description -l pl.UTF-8
44 Autor często dostaje raporty błędów w napisanych przez niego modułów.
45 Odpisując pyta się o wersję modułu, wersję Perla, system operacyjny i
46 czasem wersje powiązanych bibliotek (np. XML::Parser). W odpowiedzi
47 często dostaje "Perl 5", podczas gdy potrzebuje dokładnej wersji,
48 takiej jak wypisywana przez `perl -v`". I podobnie dla innych modułów.
49 Całą ta konwersacja może trwać wiele dni, a powinna być prostą
50 operacją - raportowaniem wersji Perla i powiązanych modułów.
51
52 Ten moduł służy do uproszczenia tego zadania. Po dodaniu "use
53 Module::Versions::Report" do programu (co jest szczególnie poręczne,
54 jeśli program służy do demonstrowania błędu w module), program po
55 uruchomieniu wypisuje raport ze szczegółami na temat wszystkich
56 modułów obecnych w pamięci, podając ich wersje (przynajmniej dla
57 modułów definiujących $VERSION).
58
59 %prep
60 %setup -q -n %{pdir}-%{pnam}-%{version}
61
62 %build
63 %{__perl} Makefile.PL \
64         INSTALLDIRS=vendor
65 %{__make}
66
67 %{?with_tests:%{__make} test}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc ChangeLog
81 %dir %{perl_vendorlib}/Module/Versions
82 %{perl_vendorlib}/Module/Versions/*.pm
83 %{_mandir}/man3/*
This page took 0.307538 seconds and 3 git commands to generate.