]> git.pld-linux.org Git - packages/perl-Module-Runtime.git/blob - perl-Module-Runtime.spec
- new
[packages/perl-Module-Runtime.git] / perl-Module-Runtime.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Module
6 %define         pnam    Runtime
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Module::Runtime - runtime module handling
9 #Summary(pl.UTF-8):     
10 Name:           perl-Module-Runtime
11 Version:        0.011
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Module/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  d0d2ab338c5bb2769a8f7db200cfdb2b
18 # generic URL, check or change before uncommenting
19 #URL:           http://search.cpan.org/dist/Module-Runtime/
20 BuildRequires:  perl-Module-Build
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with tests}
24 BuildRequires:  perl(Params::Classify)
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 The functions exported by this module deal with runtime handling of
31 Perl modules, which are normally handled at compile time.
32
33 # %description -l pl.UTF-8
34 # TODO
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Build.PL \
41         destdir=$RPM_BUILD_ROOT \
42         installdirs=vendor
43 ./Build
44
45 %{?with_tests:./Build test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 ./Build install
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorlib}/Module/*.pm
59 %{_mandir}/man3/*
This page took 0.05915 seconds and 3 git commands to generate.