]> git.pld-linux.org Git - SPECS.git/blob - perl-Math-expr_eval.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-Math-expr_eval.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Math
6 %define         pnam    expr_eval
7 Summary:        Math::expr_eval - an expression evaluator
8 Summary(pl.UTF-8):      Math::expr_eval - obliczanie wyrażeń
9 %define _ver    %(echo %{version} | tr . _)
10 Name:           perl-Math-expr_eval
11 Version:        1.0
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}_%{_ver}.zip
17 # Source0-md5:  f4962039a99c1dddf460291b1cf5feff
18 URL:            http://search.cpan.org/dist/Math-expr_eval/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  unzip
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This module is an expression evaluator. It has three main objectives:
27 efficiency, extensibility, user-friendly error messages. It's features
28 include: standard data types, arithmetic and boolean operators,
29 conditionals, pattern matching, user-defined data types, user-defined
30 binary operators and prefix unary operators, over-loaded binary
31 operators and prefix unary operators, calls to user-provided perl
32 functions, a mode for syntax checking only, optimized re-evaluation of
33 expressions, multiple symbol tables.
34
35 %description -l pl.UTF-8
36 Ten moduł służy do obliczania wyrażeń. Ma trzy główne cele: wydajność,
37 rozszerzalność i przyjazne dla użytkownika komunikaty błędów. Jego
38 możliwości obejmują: standardowe typy danych, operatory arytmetyczne i
39 logiczne, warunki, dopasowywanie wzorców, definiowalne typy danych,
40 definiowalne operatory dwuargumentowe i prefiksowe jednoargumentowe,
41 przeciążone operatory dwuargumentowe i prefiksowe jednoargumentowe,
42 wywołania dostarczonych funkcji Perla, tryb do sprawdzania składni,
43 zoptymalizowane ponowne obliczanie wyrażeń, wiele tablic symboli.
44
45 %prep
46 %setup -q -c
47
48 mv -f Makefile.pl Makefile.PL
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes README
70 %{perl_vendorlib}/Math/expr_eval.pm
This page took 0.056274 seconds and 3 git commands to generate.