]> git.pld-linux.org Git - packages/perl-Math-Random.git/blob - perl-Math-Random.spec
- cosmetics (spaces -> tabs)
[packages/perl-Math-Random.git] / perl-Math-Random.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Math
7 %define pnam    Random
8 Summary:        Math::Random - random number generators
9 Summary(pl):    Math::Random - generatory liczb losowych
10 Name:           perl-Math-Random
11 Version:        0.67
12 Release:        2
13 # same as perl except some C code
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  021006f39529940ae318c7c105d01a44
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Math::Random is a Perl port of the C version of randlib, which is
24 a suite of routines for generating random deviates.
25
26 %description -l pl
27 Math::Random jest perlowym portem napisanej w C biblioteki randlib,
28 bêd±cej zbiorem procedur do generowania liczb losowych.
29
30 %prep
31 %setup -q -n %{pdir}-%{pnam}-%{version}
32 mkdir examples
33 mv example.pl examples
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38 %{__make}
39
40 %{?with_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} install \
46         DESTDIR=$RPM_BUILD_ROOT
47
48 install -d $RPM_BUILD_ROOT%{_examplesdir}
49 cp -r examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README MANIFEST
57 %dir %{_examplesdir}/%{name}-%{version}
58 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.pl
59 %{perl_vendorarch}/%{pdir}/*.pm
60 %dir %{perl_vendorarch}/auto/%{pdir}/%{pnam}
61 %attr(755,root,root) %{perl_vendorarch}/auto/%{pdir}/%{pnam}/*.so
62 %{perl_vendorarch}/auto/%{pdir}/%{pnam}/*.ix
63 %{perl_vendorarch}/auto/%{pdir}/%{pnam}/*.bs
64 %{_mandir}/man3/*
This page took 0.060025 seconds and 4 git commands to generate.