]> git.pld-linux.org Git - packages/perl-Math-Random.git/blob - perl-Math-Random.spec
960d8ffd31cef031b5df98d57ec5abd08f331ccf
[packages/perl-Math-Random.git] / perl-Math-Random.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Math
7 %define         pnam    Random
8 Summary:        Math::Random - random number generators
9 Summary(pl.UTF-8):      Math::Random - generatory liczb losowych
10 Name:           perl-Math-Random
11 Version:        0.71
12 Release:        4
13 # same as perl except some C code
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  55d7579c670ecd180f71fd157a2d2070
18 URL:            http://search.cpan.org/dist/Math-Random/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Math::Random is a Perl port of the C version of randlib, which is
25 a suite of routines for generating random deviates.
26
27 %description -l pl.UTF-8
28 Math::Random jest perlowym portem napisanej w C biblioteki randlib,
29 będącej zbiorem procedur do generowania liczb losowych.
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33 mkdir examples
34 mv example.pl examples
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make}
40
41 %{?with_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} install \
47         DESTDIR=$RPM_BUILD_ROOT \
48         INSTALLDIRS=vendor
49
50 install -d $RPM_BUILD_ROOT%{_examplesdir}
51 cp -r examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README MANIFEST
59 %{perl_vendorarch}/Math/*.pm
60 %dir %{perl_vendorarch}/auto/Math/Random
61 %attr(755,root,root) %{perl_vendorarch}/auto/Math/Random/*.so
62 %{perl_vendorarch}/auto/Math/Random/*.ix
63 %dir %{_examplesdir}/%{name}-%{version}
64 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.pl
65 %{_mandir}/man3/*
This page took 0.023418 seconds and 3 git commands to generate.