]> git.pld-linux.org Git - SPECS.git/blob - perl-Math-Logic.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-Math-Logic.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Math
6 %define         pnam    Logic
7 Summary:        Math::Logic - pure 2, 3 or multi-value logic
8 Summary(pl.UTF-8):      Math::Logic - logika czysto 2-, 3- lub wielowartościowa
9 Name:           perl-Math-Logic
10 Version:        1.19
11 Release:        2
12 License:        LGPL
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  01352cf5bf8f4be78779ac57c033b7b5
16 URL:            http://search.cpan.org/dist/Math-Logic/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Perl's built-in logical operators, "and", "or", "xor" and "not"
24 support 2-value logic. This means that they always produce a result
25 which is either true or false. In fact Perl sometimes returns 0 and
26 sometimes returns undef for false depending on the operator and the
27 order of the arguments. For "true" Perl generally returns the first
28 value that evaluated to true which turns out to be extremely useful in
29 practice. Given the choice Perl's built-in logical operators are to be
30 preferred - but when you really want pure 2-degree logic or 3-degree
31 logic or multi-degree logic they are available through this module.
32
33 %description -l pl.UTF-8
34 Wbudowane w Perla operatory logiczne: "and", "or", "xor" i "not"
35 obsługują logikę 2-wartościową. Oznacza to, że zawsze zwracają wynik,
36 który jest prawdą lub fałszem. W rzeczywistości Perl czasami zwraca 0,
37 a czasami undef jako fałsz, w zależności od operatora i kolejności
38 argumentów. Jako "prawdę" Perl zwykle zwraca pierwszą wartość, z
39 której wyliczona została prawda, co okazuje się być bardzo przydatne w
40 praktyce. Ten moduł udostępnia logikę czysto 2-wartościową,
41 3-wartościową lub wielowartościową.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %{perl_vendorlib}/Math/Logic.pm
65 %{_mandir}/man3/*
This page took 0.944018 seconds and 3 git commands to generate.