]> git.pld-linux.org Git - SPECS.git/blob - perl-Math-LinearCombination.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / perl-Math-LinearCombination.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Math
6 %define         pnam    LinearCombination
7 Summary:        Math::LinearCombination - sum of variables with a numerical coefficient
8 Summary(pl.UTF-8):      Math::LinearCombination - suma zmiennych ze współczynnikami liczbowymi
9 Name:           perl-Math-LinearCombination
10 Version:        0.03
11 Release:        3
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  8a8b0e49dda41f288cbb8f1d384209f9
17 URL:            http://search.cpan.org/dist/Math-LinearCombination/
18 BuildRequires:  perl-Math-SimpleVariable >= 0.03
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 Requires:       perl-Math-SimpleVariable >= 0.03
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Math::LinearCombination is a module for representing mathematical
27 linear combinations of variables, i.e. expressions of the format
28
29   a1 * x1 + a2 * x2 + ... + an * xn
30
31 with x1, x2, ..., xn variables, and a1, a2, ..., an numerical
32 coefficients. Evaluation and manipulation of linear combinations is
33 also supported. The numerical coefficients a_i and variables x_i are
34 stored as pairs in an internal data structure and should not be
35 manipulated directly. All access and manipulation should be performed
36 through the methods.
37
38 %description -l pl.UTF-8
39 Math::LinearCombination to moduł służący do reprezentowania
40 matematycznych kombinacji liniowych zmiennych, czyli wyrażeń w postaci
41
42   a1 * x1 + a2 * x2 + ... + an * xn
43
44 gdzie x1, x2, ... xn to zmienne, a a1, a2, ... an to liczbowe
45 współczynniki. Obsługiwane jest także obliczanie wartości i
46 manipulowanie kombinacjami liniowymi. Współczynniki liczbowe a_i oraz
47 zmienne x_i są zapisywane jako pary w wewnętrznej strukturze danych i
48 nie powinny być modyfikowane ani odczytywane bezpośrednio, lecz przez
49 udostępnione metody.
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-%{version}
53
54 %build
55 %{__perl} Makefile.PL \
56         INSTALLDIRS=vendor
57 %{__make}
58
59 %{?with_tests:%{__make} test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc Changes README
73 %{perl_vendorlib}/Math/LinearCombination.pm
74 %{_mandir}/man3/*
This page took 0.272295 seconds and 3 git commands to generate.