]> git.pld-linux.org Git - SPECS.git/blob - perl-Math-Big.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-Math-Big.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Math
6 %define         pnam    Big
7 Summary:        Math::Big - useful routines and packages with Math::BigInt/BigFloat
8 Summary(pl.UTF-8):      Math::Big - przydatne funkcje i pakiety oparte o Math::BigInt/BigFloat
9 Name:           perl-Math-Big
10 Version:        1.12
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  5782c961f405e04c2bf1bcde309c24d2
17 URL:            http://search.cpan.org/dist/Math-Big/
18 BuildRequires:  perl-Math-BigInt >= 1.74
19 BuildRequires:  perl(Math::BigFloat) >= 1.48
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 Requires:       perl-Math-BigInt >= 1.74
23 Requires:       perl(Math::BigFloat) >= 1.48
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Math::Big module contains some routines that may come in handy when
29 you want to do some math with really, really big (or small) numbers.
30
31 %description -l pl.UTF-8
32 Moduł Math::Big zawiera trochę procedur, które mogą okazać się pomocne
33 przy obróbce bardzo, bardzo dużych (lub małych) liczb.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc BENCHMARK BUGS CHANGES CREDITS LICENSE NEW README TODO
60 %{perl_vendorlib}/Math/Big.pm
61 %{perl_vendorlib}/Math/Big
62 %{_mandir}/man3/*
63 %dir %{_examplesdir}/%{name}-%{version}
64 %{_examplesdir}/%{name}-%{version}/*.txt
65 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.pl
This page took 0.152967 seconds and 3 git commands to generate.