]> git.pld-linux.org Git - packages/perl-Makefile-Parser.git/blob - perl-Makefile-Parser.spec
- new
[packages/perl-Makefile-Parser.git] / perl-Makefile-Parser.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Makefile
6 %define         pnam    Parser
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Makefile::Parser - A simple parser for Makefiles
9 Summary(pl.UTF-8):      Makefile::Parser - prosty analizator plików Makefile
10 Name:           perl-Makefile-Parser
11 Version:        0.215
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/A/AG/AGENT/Makefile-Parser-%{version}.tar.gz
17 # Source0-md5:  f80b65da36c3fd004c8b7067e99c2c9f
18 Patch0:         %{name}-test.patch
19 URL:            http://search.cpan.org/dist/Makefile-Parser/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  sed >= 4.0
23 %if %{with tests}
24 BuildRequires:  perl-Class-Accessor
25 BuildRequires:  perl-Class-Trigger >= 0.13
26 BuildRequires:  perl-File-Slurp
27 BuildRequires:  perl-IPC-Run3 >= 0.036
28 BuildRequires:  perl-List-MoreUtils
29 BuildRequires:  perl-Makefile-DOM >= 0.005
30 %endif
31 Requires:       perl-Class-Trigger >= 0.13
32 Requires:       perl-IPC-Run3 >= 0.036
33 Requires:       perl-Makefile-DOM >= 0.005
34 BuildArch:      noarch
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 This is a simple parser for Makefiles. At this very early stage, the
39 parser only supports a limited set of features, so it may not
40 recognize most of the advanced features provided by certain make tools
41 like GNU make. Its initial purpose is to provide basic support for
42 another module named Makefile::GraphViz, which is aimed to render the
43 building process specified by a Makefile using the amazing GraphViz
44 library.
45
46 %description -l pl.UTF-8
47 Ten pakiet to prosty analizator plików Makefile. Na wstępnym etapie
48 obsługuje tylko ograniczony zbiór możliwości, więc może nie
49 rozpoznawać większości zaawansowanych możliwości niektórych
50 implementacji make, takich jak GNU make. Pierwotnym celem jest
51 zapewnienie podstawowej obsługi dla innego modułu -
52 Makefile::GraphViz, którego celem jest renderowanie procesu budowania
53 opisanego plikiem Makefile przy użyciu biblioteki GraphViz.
54
55 %prep
56 %setup -q -n %{pdir}-%{pnam}-%{version}
57 %patch0 -p1
58
59 %{__sed} -i -e '1s,/usr/bin/env perl,/usr/bin/perl,' script/*
60
61 %build
62 %{__perl} Makefile.PL \
63         INSTALLDIRS=vendor
64 %{__make}
65
66 %{?with_tests:%{__make} test}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} pure_install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc Changes README
80 %attr(755,root,root) %{_bindir}/makesimple
81 %attr(755,root,root) %{_bindir}/pgmake-db
82 %attr(755,root,root) %{_bindir}/plmake
83 %{perl_vendorlib}/Makefile/AST.pm
84 %{perl_vendorlib}/Makefile/AST
85 %{perl_vendorlib}/Makefile/Parser.pm
86 %{perl_vendorlib}/Makefile/Parser
87 %{_mandir}/man1/makesimple.1p*
88 %{_mandir}/man1/pgmake-db.1p*
89 %{_mandir}/man1/plmake.1p*
90 %{_mandir}/man3/Makefile::AST*.3pm*
91 %{_mandir}/man3/Makefile::Parser*.3pm*
This page took 0.05459 seconds and 3 git commands to generate.