]> git.pld-linux.org Git - SPECS.git/blob - perl-Make.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-Make.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Make
6 Summary:        Make - module for processing makefiles
7 Summary(pl.UTF-8):      Make - moduł do przetwarzania plików Makefile
8 Name:           perl-Make
9 Version:        1.00
10 Release:        11
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Make/Make-%{version}.tar.gz
15 # Source0-md5:  ee5233f89630451dd2c24e5e0d7d3336
16 URL:            http://search.cpan.org/dist/Make/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Make - module for processing makefiles.
24
25 %description -l pl.UTF-8
26 Make - moduł do przetwarzania plików Makefile.
27
28 %prep
29 %setup -q -n Make-%{version}
30 mv pmake pmake.pl
31 %{__perl} -pi -e '/EXE_FILES/ && s/pmake/pmake.pl/' Makefile.PL
32
33 %build
34 %{__perl} Makefile.PL \
35         INSTALLDIRS=vendor
36
37 %{?with_tests:%{__make} test}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41
42 %{__make} install \
43         DESTDIR=$RPM_BUILD_ROOT
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc Changes README
51 %attr(755,root,root) %{_bindir}/*
52 %{perl_vendorlib}/*.pm
53 %{_mandir}/man1/*
54 %{_mandir}/man3/M*
This page took 0.472948 seconds and 3 git commands to generate.