]> git.pld-linux.org Git - SPECS.git/blob - perl-Mail-DKIM.spec
SPECS updated Sun 28 Apr 15:24:02 CEST 2024
[SPECS.git] / perl-Mail-DKIM.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # do not perform "make test"
4 #
5 %define pdir    Mail
6 %define pnam    DKIM
7 Summary:        Mail::DKIM - Signs/verifies Internet mail with DKIM/DomainKey signatures
8 Summary(pl.UTF-8):      Mail::DKIM - podpisywanie/sprawdzanie poczty przy użyciu podpisów DKIM/DomainKey
9 Name:           perl-Mail-DKIM
10 Version:        1.20240124
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Mail/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  3b4eddd1f49f866020ad6d5b55cb404f
17 URL:            http://search.cpan.org/dist/Mail-DKIM/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Crypt-OpenSSL-RSA >= 0.22
22 BuildRequires:  perl-Digest-SHA
23 BuildRequires:  perl-Digest-SHA1
24 BuildRequires:  perl-Error
25 BuildRequires:  perl-Mail-AuthenticationResults >= 1.20180215
26 BuildRequires:  perl-MailTools
27 BuildRequires:  perl-Net-DNS
28 BuildRequires:  perl-Net-DNS-Resolver-Mock
29 BuildRequires:  perl-Test-RequiresInternet
30 # for YAML::XS
31 BuildRequires:  perl-YAML-LibYAML
32 %endif
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 This Perl module is part of the dkimproxy program, located at
38 <http://jason.long.name/dkimproxy/>. I've tried to abstract out the
39 DKIM parts into this module, for use in other programs.
40
41 The Mail::DKIM module uses an object-oriented interface. You use one
42 of two different classes, depending on whether you are signing or
43 verifying a message. To sign, use the Mail::DKIM::Signer class. To
44 verify, use the Mail::DKIM::Verifier class. Simple, eh?
45
46 %description -l pl.UTF-8
47 Ten moduł Perla jest częścią programu dkimproxy, który można znaleźć
48 pod <http://jason.long.name/dkimproxy/>. Jest próbą wyodrębnienia
49 części DKIM do modułu w celu umożliwienia użycia przez inne programy.
50
51 Moduł Mail::DKIM wykorzystuje interfejs zorientowany obiektowo. Używa
52 się jednej z dwóch różnych klas w zależności od działania -
53 podpisywania lub sprawdzania podpisu wiadomości. Aby podpisać, należy
54 użyć klasy Mail::DKIM::Signer. Aby sprawdzić podpis, należy użyć klasy
55 Mail::DKIM::Verifier. Proste, prawda?
56
57 %prep
58 %setup -q -n %{pdir}-%{pnam}-%{version}
59
60 %build
61 %{__perl} Makefile.PL \
62         INSTALLDIRS=vendor
63 %{__make}
64
65 %{?with_tests:%{__make} test}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc Changes README.md TODO
79 %{perl_vendorlib}/Mail/*.pm
80 %{perl_vendorlib}/Mail/DKIM
81 %{_mandir}/man3/*
This page took 0.045869 seconds and 3 git commands to generate.