]> git.pld-linux.org Git - packages/perl-MIME-Types.git/blob - perl-MIME-Types.spec
- disabled packaging Mojo::MIME replacement
[packages/perl-MIME-Types.git] / perl-MIME-Types.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    MIME
7 %define         pnam    Types
8 Summary:        MIME::Types Perl module - definition of MIME types
9 Summary(pl.UTF-8):      Moduł Perla MIME::Types - definicje typów MIME
10 Name:           perl-MIME-Types
11 Version:        2.09
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/MIME/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  99952df4f4a1e2e31eb80d98b6197774
18 URL:            http://search.cpan.org/dist/MIME-Types/
19 %{?with_tests:BuildRequires:    perl-Test-Simple >= 0.47}
20 BuildRequires:  perl-devel >= 1:5.8.8
21 BuildRequires:  perl-libnet
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 MIME types are used in MIME compliant lines, for instance as part of
28 e-mail and HTTP traffic, to indicate the type of content which is
29 transmitted. Sometimes real knowledge about a mime-type is need.
30
31 This module maintains a set of MIME::Type objects, which each describe
32 one known MIME type. There are many types defined by RFCs and vendors,
33 so the list is long but not complete.
34  
35 %description -l pl.UTF-8
36 Typy MIME są używane w liniach nagłówka zgodnych z MIME, na przykład
37 jako część transmisji e-mail lub HTTP, do określenia rodzaju
38 przesyłanej treści. Czasem potrzebna jest znajomość prawdziwego
39 mime-type.
40
41 Ten moduł utrzymuje zbiór obiektów MIME::Type, z których każdy opisuje
42 jeden znany typ MIME. Zawiera wiele typów zdefiniowanych przez RFC i
43 producentów, więc lista jest długa, ale niepełna.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make}
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/MIME/*.pod
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc ChangeLog README
69 %{perl_vendorlib}/MIME/Type.pm
70 %{perl_vendorlib}/MIME/Types.pm
71 %{perl_vendorlib}/MIME/types.db
72 %{_mandir}/man3/MIME::Type.3pm*
73 %{_mandir}/man3/MIME::Types.3pm*
74 # move it to separate package if ever needed
75 #%{perl_vendorlib}/MojoX/MIME/Types.pm
76 #%{_mandir}/man3/MojoX::MIME::Types.3pm*
This page took 0.069798 seconds and 3 git commands to generate.