]> git.pld-linux.org Git - packages/perl-Linux-Pid.git/blob - perl-Linux-Pid.spec
161556c7cb5ddf2a745930ab5471040c76a6111f
[packages/perl-Linux-Pid.git] / perl-Linux-Pid.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Linux
7 %define pnam    Pid
8 Summary:        Linux::Pid - Get the native PID and the PPID on Linux
9 Summary(pl):    Linux::Pid - uzyskiwanie natywnych PID i PPID pod Linuksem
10 Name:           perl-Linux-Pid
11 Version:        0.02
12 Release:        3
13 License:        GPL/Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  af1d6dee6ee94cc8c1847172501b468e
17 BuildRequires:  perl-devel >= 5.6
18 %if %{?_without_tests:0}%{!?_without_tests:1}
19 BuildRequires:  perl-Inline-C
20 %endif
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Linux::Pid gets the native PID and the PPID on Linux. It's useful with
27 multithreaded programs. Linux's C library returns different values of
28 the PID and the PPID from different threads. This module forces Perl
29 to call the underlying C functions getpid() and getppid().
30
31 %description -l pl
32 Linux::Pid odczytuje natywne PID i PPID pod Linuksem. Jest przydatny w
33 programach wielow±tkowych. Linuksowa biblioteka C zwraca ró¿ne
34 warto¶ci PID i PPID dla ró¿nych w±tków. Ten modu³ zmusza Perla do
35 wywo³ania funkcji C getpid() i getppid().
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{!?_without_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %{perl_vendorarch}/%{pdir}/*.pm
58 %dir %{perl_vendorarch}/auto/%{pdir}/%{pnam}
59 %attr(755,root,root) %{perl_vendorarch}/auto/%{pdir}/%{pnam}/*.so
60 %{_mandir}/man3/*
This page took 0.092946 seconds and 2 git commands to generate.