]> git.pld-linux.org Git - SPECS.git/blob - perl-LWP-Protocol-https.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-LWP-Protocol-https.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    LWP
6 %define         pnam    Protocol-https
7 Summary:        LWP::Protocol::https - Provide https support for LWP::UserAgent
8 Summary(pl.UTF-8):      LWP::Protocol::https - obsługa https dla LWP::UserAgent
9 Name:           perl-LWP-Protocol-https
10 Version:        6.10
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/LWP/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  cf64e4bc57a9266ac4343cdf0808c5c8
17 URL:            http://search.cpan.org/dist/LWP-Protocol-https/
18 BuildRequires:  perl-devel >= 1:5.8.1
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-IO-Socket-SSL >= 1:1.54
22 BuildRequires:  perl-Mozilla-CA >= 20180117
23 BuildRequires:  perl-Net-HTTP >= 6
24 BuildRequires:  perl-Test-RequiresInternet
25 BuildRequires:  perl-Test-Simple
26 BuildRequires:  perl-libwww >= 6.06
27 %endif
28 BuildRequires:  perl-Mozilla-CA >= 20180117
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 The LWP::Protocol::https module provide support for using https
34 schemed URLs with LWP. This module is a plug-in to the LWP protocol
35 handling, so you don't use it directly. Once the module is installed
36 LWP is able to access sites using HTTP over SSL/TLS.
37
38 %description -l pl.UTF-8
39 Moduł LWP::Protocol::https zapewnia obsługę URL-i ze schematu https w
40 LWP. Ten moduł jest wtyczką do obsługi protokołu w LWP, więc nie używa
41 się go bezpośrednio. Po zainstalowaniu modułu LWP potrafi łączyć się z
42 serwisami przy użyciu HTTP po SSL/TLS.
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50 %{__make}
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} pure_install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc CONTRIBUTING.md Changes Install
66 %{perl_vendorlib}/LWP/Protocol/https.pm
67 %{_mandir}/man3/LWP::Protocol::https.3pm*
This page took 1.126981 seconds and 3 git commands to generate.